aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/qmars/Makefile35
-rw-r--r--games/qmars/distinfo3
-rw-r--r--games/qmars/pkg-descr6
-rw-r--r--games/qmars/pkg-plist13
5 files changed, 58 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ac1825fc49c5..7375426f595f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -616,6 +616,7 @@
SUBDIR += qgo
SUBDIR += qix
SUBDIR += qkmj
+ SUBDIR += qmars
SUBDIR += qnetchess
SUBDIR += qnetwalk
SUBDIR += qonk
diff --git a/games/qmars/Makefile b/games/qmars/Makefile
new file mode 100644
index 000000000000..0dee8a59c3e2
--- /dev/null
+++ b/games/qmars/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: qmars
+# Date created: 2008-01-15
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmars
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= http://corewar.co.uk/ankerl/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Quicker Mars is heavily optimized to be as fast as possible
+
+BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
+
+USE_BZIP2= yes
+REINPLACE_ARGS= -i ""
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|; s|CCFLAGS =|& ${CXXFLAGS}|' \
+ ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|\./||' ${WRKSRC}/bench.*
+ @${REINPLACE_CMD} -e 's|pmars|&-server|' ${WRKSRC}/bench.pmars
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bench.* ${DATADIR}
+ ${CP} -r ${WRKSRC}/warriors ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/qmars/distinfo b/games/qmars/distinfo
new file mode 100644
index 000000000000..75aaa7d82437
--- /dev/null
+++ b/games/qmars/distinfo
@@ -0,0 +1,3 @@
+MD5 (qmars_1.1.tar.bz2) = 2b2493562af8bf98a8934d0136dd1856
+SHA256 (qmars_1.1.tar.bz2) = ee5f9535bf0dba56b069232d9052ac90b7513f68047eb9e966c6901e920dcaaf
+SIZE (qmars_1.1.tar.bz2) = 16705
diff --git a/games/qmars/pkg-descr b/games/qmars/pkg-descr
new file mode 100644
index 000000000000..9f816386f1ef
--- /dev/null
+++ b/games/qmars/pkg-descr
@@ -0,0 +1,6 @@
+QMars stands for Quicker Mars. It is a completely new implementation of a mars
+simulator, which is an interpreter of the Assembler-like language RedCode,
+which is used in CoreWars. QMars is heavily optimized to be as fast as
+possible.
+
+WWW: http://corewar.co.uk/ankerl/qmars.htm
diff --git a/games/qmars/pkg-plist b/games/qmars/pkg-plist
new file mode 100644
index 000000000000..bd4f702dad9f
--- /dev/null
+++ b/games/qmars/pkg-plist
@@ -0,0 +1,13 @@
+bin/qmars
+%%DATADIR%%/bench.exhaust
+%%DATADIR%%/bench.exmars
+%%DATADIR%%/bench.pmars
+%%DATADIR%%/bench.qmars
+%%DATADIR%%/warriors/evolver1090.rc
+%%DATADIR%%/warriors/fixed.rc
+%%DATADIR%%/warriors/jaguar.rc
+%%DATADIR%%/warriors/npaper2.rc
+%%DATADIR%%/warriors/sonofvain.rc
+%%DATADIR%%/warriors/stalker.rc
+@dirrm %%DATADIR%%/warriors
+@dirrm %%DATADIR%%