aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/xsnow/Makefile7
-rw-r--r--x11/xsnow/scripts/configure11
2 files changed, 7 insertions, 11 deletions
diff --git a/x11/xsnow/Makefile b/x11/xsnow/Makefile
index 1443209e6306..d122e1fa9d6e 100644
--- a/x11/xsnow/Makefile
+++ b/x11/xsnow/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xsnow
PORTVERSION= 1.40
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
@@ -17,6 +18,12 @@ MAINTAINER= jmz@FreeBSD.org
USE_IMAKE= yes
MAN6= xsnow.6
+pre-build:
+ @cd ${WRKSRC} && ${MV} Makefile Makefile~ && ${SED} \
+ -e 's: BINDIR .*:BINDIR=${PREFIX}/bin:' \
+ -e 's: MANDIR .*:MANDIR=${PREFIX}/man/man6:' \
+ -e 's: MANSUFFIX .*:MANSUFFIX=6:' <Makefile~ >Makefile
+
pre-install:
@${MKDIR} ${PREFIX}/bin
@${MKDIR} ${PREFIX}/man/man6
diff --git a/x11/xsnow/scripts/configure b/x11/xsnow/scripts/configure
deleted file mode 100644
index 6018f41d89db..000000000000
--- a/x11/xsnow/scripts/configure
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-cd $WRKSRC || exit 1;
-
-mv xsnow.c xsnow.c.orig
-sed -e 's/^void usleep(usec)/void Xusleep(usec)/' <xsnow.c.orig>xsnow.c
-
-echo "BINDIR=$PREFIX/bin" >> Imakefile || exit 1;
-echo "MANDIR=$PREFIX/man/man6" >> Imakefile || exit 1;
-echo "MANSUFFIX=6" >> Imakefile || exit 1;
-exit 0;