aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/festvox-pc/Makefile36
-rw-r--r--audio/festvox-pc/distinfo2
-rw-r--r--audio/festvox-pc/pkg-descr6
-rw-r--r--audio/festvox-pc/pkg-plist8
5 files changed, 53 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index cd287cf61b90..66d764d263a2 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -111,6 +111,7 @@
SUBDIR += festvox-ked8
SUBDIR += festvox-mwm
SUBDIR += festvox-ogirab
+ SUBDIR += festvox-pc
SUBDIR += festvox-rab16
SUBDIR += festvox-rab8
SUBDIR += festvox-tll
diff --git a/audio/festvox-pc/Makefile b/audio/festvox-pc/Makefile
new file mode 100644
index 000000000000..2b3238f040e2
--- /dev/null
+++ b/audio/festvox-pc/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: festvox-pc
+# Date created: 2005-02-15
+# Whom: Dario Freni
+#
+# $FreeBSD$
+#
+
+PORTNAME= festvox-pc
+PORTVERSION= 1.0
+CATEGORIES= audio accessibility
+MASTER_SITES= http://www.csrf.pd.cnr.it/Software/It-Festival/
+DISTNAME= pc_ogi_diphone
+DIST_SUBDIR= festival
+
+MAINTAINER= saturnero@gufi.org
+COMMENT= Italian male voice for Festival
+
+RUN_DEPENDS= \
+ ${LOCALBASE}/share/festival/lib/ogi_token.scm:${PORTSDIR}/audio/festival+OGI \
+ ${LOCALBASE}/share/festival/lib/dicts/ifd/lex.out:${PORTSDIR}/audio/festlex-ifd \
+ ${LOCALBASE}/share/festival/lib/italian_scm/ifd_diph_ds_dur.scm:${PORTSDIR}/audio/festogi-italian
+
+NO_BUILD= yes
+USE_ZIP= YES
+WRKSRC= ${WRKDIR}/festival
+FHOME= ${PREFIX}/share/festival
+
+post-extract:
+ @ ${CHMOD} -R 644 ${WRKSRC}
+ @ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+
+do-install:
+ ${MKDIR} ${FHOME}
+ cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+
+.include <bsd.port.mk>
diff --git a/audio/festvox-pc/distinfo b/audio/festvox-pc/distinfo
new file mode 100644
index 000000000000..be12e24aa8a8
--- /dev/null
+++ b/audio/festvox-pc/distinfo
@@ -0,0 +1,2 @@
+MD5 (festival/pc_ogi_diphone.zip) = c98b2019af2b20163250412021213f5f
+SIZE (festival/pc_ogi_diphone.zip) = 3924853
diff --git a/audio/festvox-pc/pkg-descr b/audio/festvox-pc/pkg-descr
new file mode 100644
index 000000000000..036ecf686f3e
--- /dev/null
+++ b/audio/festvox-pc/pkg-descr
@@ -0,0 +1,6 @@
+This voice provides an Italian male voice.
+It was created by ISTC-SPFD CNR & ITC-IRST.
+
+This voice can be activated via (voice_pc_ogi_diphone).
+
+WWW: http://www.csrf.pd.cnr.it/TTS/It-FESTIVAL-download.htm
diff --git a/audio/festvox-pc/pkg-plist b/audio/festvox-pc/pkg-plist
new file mode 100644
index 000000000000..894ef0bffa81
--- /dev/null
+++ b/audio/festvox-pc/pkg-plist
@@ -0,0 +1,8 @@
+share/festival/lib/voices/italian/pc_ogi_diphone/festvox/pc_ogi_diphone.scm
+share/festival/lib/voices/italian/pc_ogi_diphone/group/pc_ogi_diphone.group
+share/festival/lib/voices/italian/pc_ogi_diphone/group/pc_ogi_diphone.group-README
+@dirrm share/festival/lib/voices/italian/pc_ogi_diphone/festvox
+@dirrm share/festival/lib/voices/italian/pc_ogi_diphone/group
+@dirrm share/festival/lib/voices/italian/pc_ogi_diphone
+@unexec rmdir %D/share/festival/lib/voices/italian 2>/dev/null || true
+@unexec rmdir %D/share/festival/lib/voices 2>/dev/null || true