aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/qt23/Makefile5
-rw-r--r--x11-toolkits/qt30/Makefile5
-rw-r--r--x11-toolkits/qt31/Makefile5
-rw-r--r--x11-toolkits/qt32/Makefile5
-rw-r--r--x11-toolkits/qt33/Makefile5
5 files changed, 25 insertions, 0 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index 574991ffd7fc..8f2145bec63e 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -26,6 +26,11 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-system-libmng -thread -no-opengl \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.if defined(QT_DEBUG)
+CONFIGURE_ARGS+= -debug
+.endif
+
CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index 574991ffd7fc..8f2145bec63e 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -26,6 +26,11 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-system-libmng -thread -no-opengl \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.if defined(QT_DEBUG)
+CONFIGURE_ARGS+= -debug
+.endif
+
CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index 574991ffd7fc..8f2145bec63e 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -26,6 +26,11 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-system-libmng -thread -no-opengl \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.if defined(QT_DEBUG)
+CONFIGURE_ARGS+= -debug
+.endif
+
CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index 574991ffd7fc..8f2145bec63e 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -26,6 +26,11 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-system-libmng -thread -no-opengl \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.if defined(QT_DEBUG)
+CONFIGURE_ARGS+= -debug
+.endif
+
CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 574991ffd7fc..8f2145bec63e 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -26,6 +26,11 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-system-libmng -thread -no-opengl \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.if defined(QT_DEBUG)
+CONFIGURE_ARGS+= -debug
+.endif
+
CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"