aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/bsnmp-regex/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net-mgmt/bsnmp-regex/Makefile b/net-mgmt/bsnmp-regex/Makefile
index 160865c57a4f..951fefbdb4d1 100644
--- a/net-mgmt/bsnmp-regex/Makefile
+++ b/net-mgmt/bsnmp-regex/Makefile
@@ -15,6 +15,17 @@ COMMENT= A bsnmpd module allowing creation of counters from log files
GNU_CONFIGURE= yes
+OPTIONS= PCRE "Use PCRE instead of the default regex library" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --enable-pcre
+.else
+CONFIGURE_ARGS+= --disable-pcre
+.endif
+
MAN1= sockin.1
MAN5= bsnmp-regex.conf.5
MAN8= bsnmp-regex.8