aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/p5-Switch/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/lang/p5-Switch/Makefile b/lang/p5-Switch/Makefile
index cac4a06864eb..d802175a56e8 100644
--- a/lang/p5-Switch/Makefile
+++ b/lang/p5-Switch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Switch
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= lang perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/R/RG/RGARCIA
@@ -15,12 +16,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Switch - A switch statement for Perl
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+BUILD_DEPENDS= p5-Filter>0:${PORTSDIR}/devel/p5-Filter
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Switch.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= p5-Text-Balanced>=0:${PORTSDIR}/textproc/p5-Text-Balanced
+RUN_DEPENDS+= p5-Text-Balanced>=0:${PORTSDIR}/textproc/p5-Text-Balanced
+.endif
+
+.include <bsd.port.post.mk>