aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/fpm/Makefile42
-rw-r--r--security/fpm/distinfo4
-rw-r--r--security/fpm/files/patch-config.h137
-rw-r--r--security/fpm/files/patch-dump.c10
-rw-r--r--security/fpm/pkg-plist8
5 files changed, 13 insertions, 188 deletions
diff --git a/security/fpm/Makefile b/security/fpm/Makefile
index f91b02bb1ead..55b9f735fd79 100644
--- a/security/fpm/Makefile
+++ b/security/fpm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fpm
-PORTVERSION= 0.59
-PORTREVISION= 1
+PORTVERSION= 0.60
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,42 +17,23 @@ COMMENT= Figaro's Password Manager, an app to securely store your passwords
USE_GNOME= gnomeprefix gnomehack gnomelibs
USE_X_PREFIX= yes
USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+#CONFIGURE_ARGS+= --without-included-gettext
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-GPASSOURCE= file.c librc2.c
-GPASVERS= 1.3.0
-SOURCEFILES= blowfish.c callbacks.c fpm.c fpm_clist.c fpm_crypt.c \
- fpm_gpw.c fpm_launcher.c fpm_pref.c import_gpasman.c \
- interface.c main.c md5.c passfile.c support.c
-DOCS= AUTHORS ChangeLog README TODO
-
-GNOME_CFLAGS?= `${GNOME_CONFIG} --cflags gnomeui` \
- `${LOCALBASE}/bin/xml-config --cflags`
-GNOME_LIBS?= `${GNOME_CONFIG} --libs gnomeui` \
- `${LOCALBASE}/bin/xml-config --libs`
-CFLAGS+= -DHAVE_CONFIG_H -I. -I.. ${GNOME_CFLAGS}
+MAN1= fpm.1
+PORTDOCS= AUTHORS ChangeLog README TODO
+PLIST_FILES= bin/fpm share/gnome/pixmaps/fpm/logo.xpm
+PLIST_DIRS= share/gnome/pixmaps/fpm
pre-build:
${REINPLACE_CMD} -E -e "s@encrypt\(@bfishencrypt\(@g" ${WRKSRC}/src/blowfish.c
-do-build:
-.for f in ${GPASSOURCE}
- (cd ${WRKSRC}/src/gpasman-${GPASVERS}; ${CC} ${CFLAGS} ${GNOME_CFLAGS} -c ${f})
-.endfor
-.for f in ${SOURCEFILES}
- (cd ${WRKSRC}/src; ${CC} ${CFLAGS} ${GNOME_CFLAGS} -c ${f})
-.endfor
- (cd ${WRKSRC}/src; ${CC} ${CFLAGS} -o fpm ${SOURCEFILES:S/.c/.o/g} \
- ${GPASSOURCE:S/.c/.o/g:S/^/gpasman-${GPASVERS}\//g} ${GNOME_LIBS})
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/fpm ${PREFIX}/bin
- ${INSTALL} -d -o root -g wheel -m 0755 \
- ${PREFIX}/share/gnome/pixmaps/fpm
- ${INSTALL_DATA} ${WRKSRC}/pixmaps/logo.xpm \
- ${PREFIX}/share/gnome/pixmaps/fpm
+post-install:
.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/fpm
-.for f in ${DOCS}
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/fpm
.endfor
.endif
diff --git a/security/fpm/distinfo b/security/fpm/distinfo
index 2b9e265bd6c0..d32aea058530 100644
--- a/security/fpm/distinfo
+++ b/security/fpm/distinfo
@@ -1,2 +1,2 @@
-MD5 (fpm-0.59.tar.gz) = 28b3b89878db9dc3f555c52aa1b41afa
-SIZE (fpm-0.59.tar.gz) = 107203
+MD5 (fpm-0.60.tar.gz) = be7655d300c306c8f962f6aad0a60cc5
+SIZE (fpm-0.60.tar.gz) = 294695
diff --git a/security/fpm/files/patch-config.h b/security/fpm/files/patch-config.h
deleted file mode 100644
index b7422a8b02b1..000000000000
--- a/security/fpm/files/patch-config.h
+++ /dev/null
@@ -1,137 +0,0 @@
---- config.h.orig Sun Jun 17 15:59:07 2001
-+++ config.h Sun Jun 17 15:59:16 2001
-@@ -0,0 +1,134 @@
-+/* config.h. Generated automatically by configure. */
-+/* config.h.in. Generated automatically from configure.in by autoheader. */
-+
-+/* Define if using alloca.c. */
-+/* #undef C_ALLOCA */
-+
-+/* Define to empty if the keyword does not work. */
-+/* #undef const */
-+
-+/* Define to one of _getb67, GETB67, getb67 for Cray-2 and Cray-YMP systems.
-+ This function is required for alloca.c support on those systems. */
-+/* #undef CRAY_STACKSEG_END */
-+
-+/* Define if you have alloca, as a function or macro. */
-+#define HAVE_ALLOCA 1
-+
-+/* Define if you have <alloca.h> and it should be used (not on Ultrix). */
-+#define HAVE_ALLOCA_H 1
-+
-+/* Define if you have a working `mmap' system call. */
-+#define HAVE_MMAP 1
-+
-+/* Define as __inline if that's what the C compiler calls it. */
-+/* #undef inline */
-+
-+/* Define to `long' if <sys/types.h> doesn't define. */
-+/* #undef off_t */
-+
-+/* Define if you need to in order for stat and other things to work. */
-+/* #undef _POSIX_SOURCE */
-+
-+/* Define to `unsigned' if <sys/types.h> doesn't define. */
-+/* #undef size_t */
-+
-+/* If using the C implementation of alloca, define if you know the
-+ direction of stack growth for your system; otherwise it will be
-+ automatically deduced at run-time.
-+ STACK_DIRECTION > 0 => grows toward higher addresses
-+ STACK_DIRECTION < 0 => grows toward lower addresses
-+ STACK_DIRECTION = 0 => direction of growth unknown
-+ */
-+/* #undef STACK_DIRECTION */
-+
-+/* Define if you have the ANSI C header files. */
-+#define STDC_HEADERS 1
-+
-+#define ENABLE_NLS 1
-+/* #undef HAVE_CATGETS */
-+#define HAVE_GETTEXT 1
-+#define HAVE_LC_MESSAGES 1
-+#define HAVE_STPCPY 1
-+#define HAVE_LIBSM 1
-+#define PACKAGE_LOCALE_DIR "/usr/local/share/locale"
-+/* #undef PACKAGE_DATA_DIR */
-+/* #undef PACKAGE_SOURCE_DIR */
-+
-+/* Define if you have the __argz_count function. */
-+#define HAVE___ARGZ_COUNT 1
-+
-+/* Define if you have the __argz_next function. */
-+#define HAVE___ARGZ_NEXT 1
-+
-+/* Define if you have the __argz_stringify function. */
-+#define HAVE___ARGZ_STRINGIFY 1
-+
-+/* Define if you have the dcgettext function. */
-+#define HAVE_DCGETTEXT 1
-+
-+/* Define if you have the getcwd function. */
-+#define HAVE_GETCWD 1
-+
-+/* Define if you have the getpagesize function. */
-+#define HAVE_GETPAGESIZE 1
-+
-+/* Define if you have the munmap function. */
-+#define HAVE_MUNMAP 1
-+
-+/* Define if you have the putenv function. */
-+#define HAVE_PUTENV 1
-+
-+/* Define if you have the setenv function. */
-+#define HAVE_SETENV 1
-+
-+/* Define if you have the setlocale function. */
-+#define HAVE_SETLOCALE 1
-+
-+/* Define if you have the stpcpy function. */
-+#define HAVE_STPCPY 1
-+
-+/* Define if you have the strcasecmp function. */
-+#define HAVE_STRCASECMP 1
-+
-+/* Define if you have the strchr function. */
-+#define HAVE_STRCHR 1
-+
-+/* Define if you have the strdup function. */
-+#define HAVE_STRDUP 1
-+
-+/* Define if you have the <X11/SM/SMlib.h> header file. */
-+#define HAVE_X11_SM_SMLIB_H 1
-+
-+/* Define if you have the <argz.h> header file. */
-+#define HAVE_ARGZ_H 1
-+
-+/* Define if you have the <limits.h> header file. */
-+#define HAVE_LIMITS_H 1
-+
-+/* Define if you have the <locale.h> header file. */
-+#define HAVE_LOCALE_H 1
-+
-+/* Define if you have the <malloc.h> header file. */
-+#define HAVE_MALLOC_H 1
-+
-+/* Define if you have the <nl_types.h> header file. */
-+#define HAVE_NL_TYPES_H 1
-+
-+/* Define if you have the <string.h> header file. */
-+#define HAVE_STRING_H 1
-+
-+/* Define if you have the <sys/param.h> header file. */
-+#define HAVE_SYS_PARAM_H 1
-+
-+/* Define if you have the <unistd.h> header file. */
-+#define HAVE_UNISTD_H 1
-+
-+/* Define if you have the i library (-li). */
-+/* #undef HAVE_LIBI */
-+
-+/* Name of package */
-+#define PACKAGE "fpm"
-+
-+/* Version number of package */
-+#define VERSION "0.59"
-+
diff --git a/security/fpm/files/patch-dump.c b/security/fpm/files/patch-dump.c
deleted file mode 100644
index 647b2e11d2f7..000000000000
--- a/security/fpm/files/patch-dump.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/gpasman-1.3.0/dump.c.orig Mon Dec 22 17:49:29 2003
-+++ src/gpasman-1.3.0/dump.c Mon Dec 22 17:49:38 2003
-@@ -30,6 +30,7 @@
- #include <glib.h>
- #include <string.h>
- #include <stdlib.h>
-+#include <sys/types.h>
-
- #include "file.h"
-
diff --git a/security/fpm/pkg-plist b/security/fpm/pkg-plist
deleted file mode 100644
index 5567f569618b..000000000000
--- a/security/fpm/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/fpm
-share/gnome/pixmaps/fpm/logo.xpm
-@dirrm share/gnome/pixmaps/fpm
-%%PORTDOCS%%share/doc/fpm/AUTHORS
-%%PORTDOCS%%share/doc/fpm/ChangeLog
-%%PORTDOCS%%share/doc/fpm/README
-%%PORTDOCS%%share/doc/fpm/TODO
-%%PORTDOCS%%@dirrm share/doc/fpm