aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/libsoup/Makefile4
-rw-r--r--devel/libsoup22/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index 2eff113b564e..ab80e23e0f9e 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -25,8 +25,8 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
PLIST_SUB= VERSION="2.2"
diff --git a/devel/libsoup22/Makefile b/devel/libsoup22/Makefile
index 2eff113b564e..ab80e23e0f9e 100644
--- a/devel/libsoup22/Makefile
+++ b/devel/libsoup22/Makefile
@@ -25,8 +25,8 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
PLIST_SUB= VERSION="2.2"