aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.desc.mk1
-rw-r--r--multimedia/libdvdread/Makefile14
2 files changed, 7 insertions, 8 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index d5a9bb5fa611..7cd739390bda 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -37,6 +37,7 @@ DEBUG_DESC?= Enable debug flags
DEVD_DESC?= Install devd files
DOCS_DESC?= Build and install the documentation
DV_DESC?= Enable libDV support
+DVDCSS_DESC?= Enable libdvdcss support
ECW_DESC?= Enable ECW support
ESOUND_DESC?= Enable Esound sound server support
EXAMPLES_DESC?= Build and install the examples
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 7c521d281b29..bcb651482f12 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdvdread
PORTVERSION= 4.2.0
+PORTREVISION= 1
CATEGORIES= multimedia
# Svn repository URL : svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdread
MASTER_SITES= http://dvdnav.mplayerhq.hu/releases/ \
@@ -32,21 +33,18 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" \
USE_GMAKE= yes
USE_LDCONFIG= yes
-.if defined(PACKAGE_BUILDING)
-DVDCSS_OPTION= off
-.else
-DVDCSS_OPTION= on
+OPTIONS_DEFINE= DVDCSS
+.if !defined(PACKAGE_BUILDING)
+OPTIONS_DEFAULT= DVDCSS
.endif
-OPTIONS= DVDCSS "Include libdvdcss support" ${DVDCSS_OPTION}
-
# DVDCSS version hardcoded in src/dvd_input.c (dlopen'ed)
DVDCSS_LIBVERSION= 3
.include <bsd.port.pre.mk>
-.if defined(WITH_DVDCSS)
-LIB_DEPENDS+= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/multimedia/libdvdcss
+.if ${PORT_OPTIONS:MDVDCSS}
+LIB_DEPENDS+= dvdcss:${PORTSDIR}/multimedia/libdvdcss
.endif
post-patch: