aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/fairymax/Makefile15
-rw-r--r--games/ioquake3/Makefile72
-rw-r--r--games/tuxpaint-fonts/Makefile21
3 files changed, 51 insertions, 57 deletions
diff --git a/games/fairymax/Makefile b/games/fairymax/Makefile
index 997cff8be1e8..d8a8534c06a5 100644
--- a/games/fairymax/Makefile
+++ b/games/fairymax/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: fairymax
-# Date created: 22 April 2011
-# Whom: Kalten <kalten@gmx.at>
-#
+# Created by: Kalten <kalten@gmx.at>
# $FreeBSD$
-#
PORTNAME= fairymax
PORTVERSION= 4.8Q
@@ -18,7 +14,8 @@ COMMENT= Chess engine for shatranj, courier chess, and others
CONFLICTS= fairymax-4.8Q.[0-9]* fairymax-4.8Q.[0-9]*_[0-9]*
-OPTIONS+= OCFLAGS "Use optimized compiler flags" on
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+OPTIONS_DEFAUTL= OPTIMIZED_CFLAGS
DIST_SUBDIR= ${PORTNAME}
@@ -40,10 +37,10 @@ MAKE_ARGS+= INI_FILE_fmax=${DATADIR}/fmax.ini \
.include <bsd.port.options.mk>
-.if defined(WITHOUT_OCFLAGS) && !defined(WITH_OCFLAGS)
-CFLAGS+=
-.else
+.if ! ${PORT_OPTIONS:MOCFLAGS}
CFLAGS+= -O2
+.else
+CFLAGS+=
.endif
post-patch:
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 48984fc08f57..5faf483e6de7 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -30,25 +30,28 @@ WITHOUT_DLRENDERER= yes
# Client config
WITH_CLIENT= yes
WITHOUT_DEDICATED= yes
-OPTIONS+= SERVER "Install dedicated server" on \
- CURL "Enable cURL for http/ftp download" on \
- OPENAL "Enable OpenAL audio output" on \
- MUMBLE "Enable Mumble support (no dependencies)" on \
- VORBIS "Enable Ogg Vorbis support" on
+OPTIONS_DEFINE= SERVER CURL OPENAL MUMBLE VORBIS DEBUG
+OPTIONS_DEFAULT= SERVER CURL OPENAL MUMBLE VORBIS
+SERVER_DESC= Install dedicated server
+MUMBLE_DESC= Enable Mumble support (no dependencies)
. if defined(NO_TOOLS)
WITHOUT_TOOLS= yes
. else
-OPTIONS+= TOOLS "Enable modding tools" on
+OPTIONS_DEFINE+= TOOLS
+OPTIONS_DEFAULT+= TOOLS
+TOOLS_DESC= Enable modding tools
. endif
. if defined(HAS_DLRENDERER)
-OPTIONS+= DLRENDERER "Build dynamically loaded renderer" on
-. else
-WITHOUT_DLRENDERER= yes
+OPTIONS_DEFINE+= DLRENDERER
+OPTIONS_DEFAULT+= DLRENDERER
+DLRENDERER_DESC= Build dynamically loaded renderer
. endif
.endif
# Common config
.if !defined(NO_GAMELIBS)
-OPTIONS+= GAMELIBS "Build game libraries" off
+OPTIONS_DEFINE+= GAMELIBS
+OPTIONS_DEFAULT+= GAMELIBS
+GAMELIBS_DESC= Build game libraries
.endif
MAKE_ARGS+= DEFAULT_BASEDIR="${Q3DIR}" \
@@ -85,49 +88,42 @@ ONLY_FOR_ARCHS= amd64 i386
.include <bsd.port.options.mk>
-.if defined(NO_GAMELIBS) && defined(WITH_GAMELIBS)
-IGNORE= does not support WITH_GAMELIBS
-.endif
-.if !defined(HAS_DLRENDERER) && defined(WITH_DLRENDERER)
-IGNORE= does not support WITH_DLRENDERER
-.endif
-
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
ALL_TARGET= debug
.endif
-.if !defined(WITHOUT_SERVER)
+.if ${PORT_OPTIONS:MSERVER}
RUN_DEPENDS+= ${Q3SERVER}${BINSUFFIX}:${PORTSDIR}/games/${PORTNAME}-server
.endif
.if !defined(DESKTOP_ENTRIES)
-. if !defined(WITHOUT_CLIENT)
+. if ${PORT_OPTIONS:MCLIENT}
DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER}" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}${BINSUFFIX}" "Game;" false
. endif
-. if defined(WITH_SMP)
+. if ${PORT_OPTIONS:MSMP}
DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER} SMP" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}-smp${BINSUFFIX}" "Game;" false
. endif
.endif
-.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
- !defined(WITH_SMP)
+.if ! ${PORT_OPTIONS:MCLIENT} && ! ${PORT_OPTIONS:MDEDICATED} && \
+ ! ${PORT_OPTIONS:MSMP}
IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
.endif
-.if !defined(WITHOUT_CLIENT) || defined(WITH_SMP)
+.if ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MSMP}
# cURL
-.if !defined(WITHOUT_CURL)
+.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
MAKE_ARGS+= USE_CURL=1 USE_CURL_DLOPEN=0
.else
MAKE_ARGS+= USE_CURL=0
.endif
# OpenAL
-.if !defined(WITHOUT_OPENAL)
+.if ${PORT_OPTIONS:MOPENAL}
USE_OPENAL= al
MAKE_ARGS+= USE_OPENAL=1 USE_OPENAL_DLOPEN=0
.else
@@ -136,14 +132,14 @@ MAKE_ARGS+= USE_OPENAL=0
# SDL
USE_SDL= sdl
# Vorbis
-.if !defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
MAKE_ARGS+= USE_CODEC_VORBIS=1
.else
MAKE_ARGS+= USE_CODEC_VORBIS=0
.endif
# Mumble
-.if !defined(WITHOUT_MUMBLE)
+.if ${PORT_OPTIONS:MMUMBLE}
MAKE_ARGS+= USE_MUMBLE=1
.else
MAKE_ARGS+= USE_MUMBLE=0
@@ -154,7 +150,7 @@ WITHOUT_DLRENDERER= yes
.endif
# SMP is only built with CLIENT.
-.if !defined(WITHOUT_CLIENT) || defined(WITH_SMP)
+.if ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MSMP}
MAKE_ARGS+= BUILD_CLIENT=1
PLIST_SUB+= CLIENT=""
Q3BIN+= ${Q3CLIENT}
@@ -163,7 +159,7 @@ MAKE_ARGS+= BUILD_CLIENT=0
PLIST_SUB+= CLIENT="@comment "
.endif
-.if !defined(WITHOUT_DEDICATED)
+.if ${PORT_OPTIONS:MDEDICATED}
MAKE_ARGS+= BUILD_SERVER=1
PLIST_SUB+= DEDICATED=""
Q3BIN+= ${Q3SERVER}
@@ -172,7 +168,7 @@ MAKE_ARGS+= BUILD_SERVER=0
PLIST_SUB+= DEDICATED="@comment "
.endif
-.if defined(WITH_GAMELIBS)
+.if ${PORT_OPTIONS:MGAMELIBS}
MAKE_ARGS+= BUILD_GAME_SO=1
PLIST_SUB+= GAMELIBS=""
.else
@@ -180,7 +176,7 @@ PLIST_SUB+= GAMELIBS="@comment "
.endif
# Note that SMP is only supported on OS-X, hence the option has been removed.
-.if defined(WITH_SMP)
+.if ${PORT_OPTIONS:MSMP}
MAKE_ARGS+= BUILD_CLIENT_SMP=1
PLIST_SUB+= SMP=""
Q3BIN+= ${Q3CLIENT}-smp
@@ -189,7 +185,7 @@ MAKE_ARGS+= BUILD_CLIENT_SMP=0
PLIST_SUB+= SMP="@comment "
.endif
-.if !defined(WITHOUT_DLRENDERER)
+.if ${PORT_OPTIONS:MDLRENDERER}
PLIST_SUB+= DLRENDERER=""
MAKE_ARGS+= USE_RENDERER_DLOPEN=1
.else
@@ -197,7 +193,7 @@ MAKE_ARGS+= USE_RENDERER_DLOPEN=0
PLIST_SUB+= DLRENDERER="@comment "
.endif
-.if !defined(WITHOUT_TOOLS)
+.if ${PORT_OPTIONS:MTOOLS}
PLIST_SUB+= TOOLS=""
.else
PLIST_SUB+= TOOLS="@comment "
@@ -208,25 +204,25 @@ do-install: ${Q3INSTALL}
${INSTALL_PROGRAM} ${BUILDDIR}/${bin}.${ARCH} \
${PREFIX}/bin/${bin}${BINSUFFIX}
.endfor
-.if !defined(WITHOUT_TOOLS)
+.if ${PORT_OPTIONS:MTOOLS}
.for bin in ${Q3TOOLS}
${INSTALL_PROGRAM} ${BUILDDIR}/tools/${bin} \
${PREFIX}/bin/${bin}${BINSUFFIX}
.endfor
.endif
-.if !defined(WITHOUT_DLRENDERER)
+.if ${PORT_OPTIONS:MDLRENDERER}
.for renderer in ${Q3RENDERER}
${MKDIR} ${LIBDIR}
${INSTALL_LIB} ${BUILDDIR}/${renderer}.so ${LIBDIR}
.endfor
.endif
-.if defined(WITH_GAMELIBS)
+.if ${PORT_OPTIONS:MGAMELIBS}
.for dir in ${Q3BASE}
${MKDIR} ${LIBDIR}/${dir}
${INSTALL_LIB} ${BUILDDIR}/${dir}/*.so ${LIBDIR}/${dir}
.endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/games/tuxpaint-fonts/Makefile b/games/tuxpaint-fonts/Makefile
index 8b042f473952..c9262008b7b4 100644
--- a/games/tuxpaint-fonts/Makefile
+++ b/games/tuxpaint-fonts/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tuxpaint-fonts
-# Date created: 15 Jul 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= tuxpaint
PORTVERSION= 2004.06.05
@@ -33,9 +29,14 @@ CHINESE_SIMPLIFIED_CODE= zh_cn
KOREAN_CODE= ko
VIETNAMESE_CODE= vi
+#Bmake compatibility
+.MAKE.FreeBSD_UL= yes
+
# Generate options menu.
.for l in ${LANGS}
-OPTIONS+= ${l:U} "${l:S/_/ /} fonts" on
+OPTIONS_DEFINE+= ${l:U}
+OPTIONS_DEFAULT+= ${l:U}
+${l:U}_DESC= ${l:S/_/ /} fonts
.endfor
# Set MASTER_SITES
@@ -46,11 +47,11 @@ MASTER_SITES+= SF/${PORTNAME}/${PORTNAME}-fonts/${${l:U}_DISTNAME}:${l:U}
# Do not use the same OPTIONS directory as "games/tuxpaint".
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Set DISTFILES and PLIST_FILES according to OPTIONS.
.for l in ${LANGS}
-. if !defined(WITHOUT_${l:U})
+. if ${PORT_OPTIONS:M${l:U}}
DISTFILES+= ${PORTNAME}-ttf-${${l:U}_DISTNAME}${EXTRACT_SUFX}:${l:U}
PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}.ttf
PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/COPYING.txt
@@ -63,7 +64,7 @@ PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs
do-install:
${MKDIR} ${DATADIR}/fonts/locale
.for l in ${LANGS}
-. if defined(WITH_${l:U})
+. if ${PORT_OPTIONS:M${l:U}}
${INSTALL_DATA} \
${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/${${l:U}_CODE}.ttf \
${DATADIR}/fonts/locale
@@ -74,4 +75,4 @@ do-install:
. endif
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
-14 10:59:40 +0800'>2011-11-142-4/+4 * - Update to 20111102sunpoet2011-11-072-3/+3 * - Update to 20111025sunpoet2011-10-302-3/+3 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-2/+0 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-175-37/+270 * - Update to 20110928sunpoet2011-10-032-3/+3 * - Update to 20110909sunpoet2011-09-192-3/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/mythessunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hyphensunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-4/+5 * - Change MASTER_SITES to my LOCAL to avoid implicit change of non-versionedsunpoet2011-08-184-8/+8 * - Update to 20110814sunpoet2011-08-162-3/+3 * - Update to 20110813sunpoet2011-08-152-4/+3 * - Set WRKSRCsunpoet2011-08-131-1/+2 * - Unify COMMENT and pkg-descrsunpoet2011-08-132-2/+2 * - Use WRKSRCsunpoet2011-08-121-1/+1 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-031-2/+0 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-293-29/+29 * - Fix typosunpoet2011-07-251-1/+1 * Pass matainership to the new office teambapt2011-07-223-3/+3 * Add some locales thesaurusbapt2011-07-214-0/+41 * Add Portuguese hyphenation rulesbapt2011-07-214-0/+35 * Add portuguese and bresilian hunspell dictionnarybapt2011-07-204-0/+49 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-084-4/+4 * Update KDE Software Compilation ports to 4.6.5makc2011-07-085-5/+195 * - remove MD5ohauer2011-07-031-1/+0 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.4. Read fullavilla2011-06-142-4/+4 * Update KDE Software Compilation ports to 4.6.3makc2011-05-174-4/+102 * - Update KOffice to 2.3.3.avilla2011-04-134-8/+8 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-073-4/+22 * - Update KOffice to 2.3.1.avilla2011-03-258-186/+76 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-256-51/+200 * - Get Rid MD5 supportmiwi2011-03-1910-10/+0 * - Remove unnecessary PKGNAMEPREFIX declarationsunpoet2011-01-094-4/+0 * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-082-4/+4