aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/archmbox/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/mail/archmbox/Makefile b/mail/archmbox/Makefile
index 540ef6c973f9..4a0186e072ef 100644
--- a/mail/archmbox/Makefile
+++ b/mail/archmbox/Makefile
@@ -7,33 +7,26 @@ PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= SF/adc-${PORTNAME}/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Email archiver that parses mailboxes and performs actions
LICENSE= GPLv2
USES= perl5
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PERL="${PERL}"
-MAN1= archmbox.1
-PLIST_FILES= bin/archmbox
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
PORTDOCS= ChangeLog NEWS README THANKS TODO
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
# Linux fuser(1) is incompatible with FreeBSD one, do not look for it
@${REINPLACE_CMD} -e '/for ac_prog in/s, fuser,,' \
${WRKSRC}/configure
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>