aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/thoteditor/Makefile15
-rw-r--r--emulators/xcpc/Makefile8
-rw-r--r--emulators/xzx/Makefile3
-rw-r--r--ftp/llnlxdir/Makefile3
-rw-r--r--ftp/llnlxftp/Makefile3
-rw-r--r--games/CaribbeanStud/Makefile6
-rw-r--r--games/d2x-xl/Makefile3
-rw-r--r--games/imaze/Makefile2
-rw-r--r--games/xabacus/Makefile2
-rw-r--r--games/xbill/Makefile6
-rw-r--r--games/xminehunter/Makefile10
-rw-r--r--games/xshisen/Makefile8
-rw-r--r--games/znibbles/Makefile8
-rw-r--r--graphics/SciPlot/Makefile5
-rw-r--r--graphics/geomview/Makefile8
-rw-r--r--graphics/ida/Makefile4
-rw-r--r--graphics/inventor/Makefile10
-rw-r--r--graphics/libGLw/Makefile3
-rw-r--r--graphics/opendx/Makefile4
-rw-r--r--graphics/plotutils/Makefile10
-rw-r--r--graphics/white_dune/Makefile9
-rw-r--r--graphics/xmfract/Makefile4
-rw-r--r--graphics/xpdf/Makefile4
23 files changed, 44 insertions, 94 deletions
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index b2556f641bb0..792fe3c23398 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: thot
-# Date created: 1 Aug 1997
-# Whom: Pedro Giffuni (orig)
-#
+# Created by: Pedro Giffuni
# $FreeBSD$
-#
PORTNAME= thoteditor
PORTVERSION= 2.1e
@@ -15,21 +11,20 @@ MASTER_SITE_SUBDIR= apps/editors/X/thot
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An structured document editor, offering a graphical WYSIWYG interface
-
-.include <bsd.port.pre.mk>
+COMMENT= Structured document editor, offering a graphical WYSIWYG interface
THOT_SUBDIR= Target
-USE_MOTIF= yes
+USES= gmake motif
WRKSRC= $(WRKDIR)/Thot/$(THOT_SUBDIR)
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
-USE_GMAKE= yes
ALL_TARGET= all schemas
MAKE_JOBS_UNSAFE= yes
MAN1= cextract.1
MAN5= cextrc.5
+.include <bsd.port.pre.mk>
+
do-configure:
$(CP) $(WRKSRC)/../thot/Makefile.in $(WRKSRC)/../thot/Makefile.in.patched
$(SED) -e "s&%%MOTIFLIB%%&$(MOTIFLIB)&" <$(WRKSRC)/../thot/Makefile.in.patched >$(WRKSRC)/../thot/Makefile.in
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
index 131fef2865ee..f1c3201d148d 100644
--- a/emulators/xcpc/Makefile
+++ b/emulators/xcpc/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= pixel@hugbox.org
-COMMENT= A portable Amstrad 464&/664/6128 emulator
+COMMENT= Portable Amstrad 464&/664/6128 emulator
HAS_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -29,7 +29,7 @@ MOTIF_DESC= With Motif widget set
ATHENA_DESC= With Athen widget set
XSHM_DESC= With XShm support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
@@ -44,7 +44,7 @@ CONFIGURE_ARGS+=--disable-xshm
.endif
.if ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF=yes
+USES+= motif
CONFIGURE_ARGS+=--with-motif1
.else
CONFIGURE_ARGS+=--without-motif1
@@ -57,4 +57,4 @@ CONFIGURE_ARGS+=--with-athena
CONFIGURE_ARGS+=--without-athena
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/xzx/Makefile b/emulators/xzx/Makefile
index f396bef633f5..36cf3c44a1f0 100644
--- a/emulators/xzx/Makefile
+++ b/emulators/xzx/Makefile
@@ -11,9 +11,8 @@ DISTNAME= ${PORTNAME}-pro-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= ZX Spectrum (48K/128K/+3) Emulator for X11
-USES= imake:env
+USES= imake:env motif
-USE_MOTIF= yes
USE_XORG= x11 ice sm xext xpm xt xxf86vm
# License forbids redistribution
diff --git a/ftp/llnlxdir/Makefile b/ftp/llnlxdir/Makefile
index 2e2aa93e70ac..9f5320ec87c7 100644
--- a/ftp/llnlxdir/Makefile
+++ b/ftp/llnlxdir/Makefile
@@ -16,8 +16,7 @@ PLIST_FILES= bin/xdir lib/X11/app-defaults/XDir
MAN1= xdir.1
WRKSRC= ${WRKDIR}/llnlxdir2_1_2/sources
-USES= imake
-USE_MOTIF= yes
+USES= imake motif
USE_XORG= ice sm x11 xext xp xt
.include <bsd.port.mk>
diff --git a/ftp/llnlxftp/Makefile b/ftp/llnlxftp/Makefile
index 669316c4efd3..acea057529a2 100644
--- a/ftp/llnlxftp/Makefile
+++ b/ftp/llnlxftp/Makefile
@@ -14,8 +14,7 @@ COMMENT= Motif FTP client
PLIST_FILES= bin/xftp lib/X11/app-defaults/XFtp
WRKSRC= ${WRKDIR}/llnlxftp2.1/sources
-USES= imake
-USE_MOTIF= yes
+USES= imake motif
USE_XORG= ice sm x11 xext xp xt
CFLAGS+= -Wno-implicit-int \
diff --git a/games/CaribbeanStud/Makefile b/games/CaribbeanStud/Makefile
index c99fbfcf73b7..88079faa4f28 100644
--- a/games/CaribbeanStud/Makefile
+++ b/games/CaribbeanStud/Makefile
@@ -1,6 +1,4 @@
-# New ports collection makefile for: CaribbeanStud
-# Date created: 4 July 1998
-# Whom: Andrey Zakhvatov
+# Created by: Andrey Zakhvatov
#
# $FreeBSD$
#
@@ -17,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Caribbean Stud gambling game for X Window System
MAKEFILE= Xmakefile
-USE_MOTIF= yes
+USES= motif
CFLAGS+= -Wno-deprecated
do-install:
diff --git a/games/d2x-xl/Makefile b/games/d2x-xl/Makefile
index 6fddcaab2841..c125a1d6ad74 100644
--- a/games/d2x-xl/Makefile
+++ b/games/d2x-xl/Makefile
@@ -24,9 +24,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug --enable-release=yes \
--with-sharepath=${PREFIX}/share/d2x-xl
USE_SDL= sdl mixer image
-USE_GMAKE= yes
+USES= gmake motif
USE_AUTOTOOLS= aclocal autoheader automake autoconf
-USE_MOTIF= yes
MAKE_JOBS_SAFE= yes
AUTOMAKE_ARGS= --add-missing --copy
diff --git a/games/imaze/Makefile b/games/imaze/Makefile
index 6c4f99694612..9758797acbbe 100644
--- a/games/imaze/Makefile
+++ b/games/imaze/Makefile
@@ -49,7 +49,7 @@ TOOLKIT= athena
.endif
.if ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES+= motif
TOOLKIT= motif
.endif
diff --git a/games/xabacus/Makefile b/games/xabacus/Makefile
index 168be3847972..2f30a3777bf8 100644
--- a/games/xabacus/Makefile
+++ b/games/xabacus/Makefile
@@ -26,7 +26,7 @@ MAN6= xabacus.6
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES= motif
.else
CONFIGURE_ARGS+= --without-motif
.endif
diff --git a/games/xbill/Makefile b/games/xbill/Makefile
index d9ac2b16fe50..5c6feb51f22f 100644
--- a/games/xbill/Makefile
+++ b/games/xbill/Makefile
@@ -35,7 +35,7 @@ ATHENA_DESC= Athena widget set
GTK_DESC= GTK widget set
MOTIF_DESC= Motif widget set
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATHENA}
CONFIGURE_ARGS+= --disable-gtk --disable-motif
@@ -43,7 +43,7 @@ USE_XORG= xaw xmu xt x11 sm ice
.elif ${PORT_OPTIONS:MMOTIF}
CONFIGURE_ARGS+= --disable-athena --disable-gtk
USE_XORG= xt x11 sm ice xpm
-USE_MOTIF= yes
+USES= motif
.else # ${PORT_OPTIONS:MGTK}
CONFIGURE_ARGS+= --disable-athena --disable-motif
USE_GNOME= gtk12
@@ -54,4 +54,4 @@ post-patch:
@${REINPLACE_CMD} -e '/WIDGET_LIBS=/ s|-lXm"$$|-lXm -lXpm"|' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xminehunter/Makefile b/games/xminehunter/Makefile
index 9e36449a8b66..25eb38fd0f8b 100644
--- a/games/xminehunter/Makefile
+++ b/games/xminehunter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xminehunter
-# Date created: 09 January 1997
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xminehunter
PORTVERSION= 0.4
@@ -13,11 +9,11 @@ MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Motif minesweeper game
+COMMENT= Motif minesweeper game
+USES= motif
USE_XORG= xpm
WRKSRC= ${WRKDIR}/xminehunter
-USE_MOTIF= yes
ALL_TARGET= xminehunter
.include <bsd.port.mk>
diff --git a/games/xshisen/Makefile b/games/xshisen/Makefile
index 717492c453ad..ebed99cca06b 100644
--- a/games/xshisen/Makefile
+++ b/games/xshisen/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xshisen
-# Date created: 9 Oct 1996
-# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
-#
+# Created by: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
# $FreeBSD$
-#
PORTNAME= xshisen
PORTVERSION= 1.51
@@ -24,7 +20,7 @@ MANLANG= "" ja
MAN6= xshisen.6
.if !defined(WITHOUT_MOTIF)
-USE_MOTIF= yes
+USES= motif
CONFIGURE_ARGS+= --with-motif
.endif
diff --git a/games/znibbles/Makefile b/games/znibbles/Makefile
index 5beea89c4e2e..4a2c9cbd07ef 100644
--- a/games/znibbles/Makefile
+++ b/games/znibbles/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: znibbles
-# Date created: 21 Aug 1999
-# Whom: Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
-#
+# Created by: Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= znibbles
PORTVERSION= 0.0.7
@@ -21,7 +17,7 @@ LICENSE_COMB= dual
OPTIONS_DEFINE= GTK1
OPTIONS_DEFAULT= GTK1
-USE_MOTIF= yes
+USES= motif
WANT_GNOME= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/SciPlot/Makefile b/graphics/SciPlot/Makefile
index 0e36024482dc..c67410e02fb5 100644
--- a/graphics/SciPlot/Makefile
+++ b/graphics/SciPlot/Makefile
@@ -1,7 +1,5 @@
# Created by: thierry@pompo.net
-#
# $FreeBSD$
-#
PORTNAME= SciPlot
PORTVERSION= 1.36
@@ -13,8 +11,7 @@ MASTER_SITE_SUBDIR= widgets
MAINTAINER= thierry@FreeBSD.org
COMMENT= Full-featured Xt widget to display 2D data in a graph
-USES= imake
-USE_MOTIF= yes
+USES= imake motif
USE_XORG= xp
MAKE_ENV= EXTRA_DEFINES="-fPIC" LIBNAME=${LIBNAME}
USE_LDCONFIG= yes
diff --git a/graphics/geomview/Makefile b/graphics/geomview/Makefile
index 69c98d707cc2..3010dd403ced 100644
--- a/graphics/geomview/Makefile
+++ b/graphics/geomview/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: geomview
-# Date created: 5 November 1996
-# Whom: fenner
-#
+# Created by: fenner
# $FreeBSD$
-#
PORTNAME= geomview
PORTVERSION= 1.9.4
@@ -20,8 +16,8 @@ NOT_FOR_ARCHS_REASON= Segfaults on amd64
OPTIONS_DEFINE= MOTION_AVG DOCS EXAMPLES
MOTION_AVG_DESC= Use experimental motion averaging code
+USES= motif
USE_BZIP2= yes
-USE_MOTIF= yes
USE_GL= glu
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-motif=${LOCALBASE} --with-opengl=${LOCALBASE}
diff --git a/graphics/ida/Makefile b/graphics/ida/Makefile
index 9990088ab95c..1c64e94c239e 100644
--- a/graphics/ida/Makefile
+++ b/graphics/ida/Makefile
@@ -21,10 +21,8 @@ OPTIONS_DEFAULT= GIF PNG TIFF
PCD_DESC= Enable PhotoCD support
SANE_DESC= Enable SANE support
-USE_MOTIF= yes
USE_PERL5_BUILD=yes
-USES= iconv
-USE_GMAKE= yes
+USES= iconv gmake motif
MAKEFILE= GNUmakefile
MAKE_ARGS= JPEG_VER=80 verbose=yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/inventor/Makefile b/graphics/inventor/Makefile
index d63a35c81303..0ada5e8a8908 100644
--- a/graphics/inventor/Makefile
+++ b/graphics/inventor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: OpenInventor
-# Date created: 14 December 2002
-# Whom: Christian Gusenbauer
-#
+# Created by: Christian Gusenbauer
# $FreeBSD$
-#
PORTNAME= inventor
PORTVERSION= 2.1.5.p10
@@ -24,9 +20,7 @@ CONFLICTS= Coin-* SoXt-*
USE_XORG= x11 xi
USE_GL= glw
-USE_GMAKE= yes
-USES= iconv
-USE_MOTIF= yes
+USES= iconv gmake motif
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/graphics/libGLw/Makefile b/graphics/libGLw/Makefile
index 655986da0b20..8f4d0c4dfcde 100644
--- a/graphics/libGLw/Makefile
+++ b/graphics/libGLw/Makefile
@@ -12,10 +12,9 @@ MAINTAINER= x11@FreeBSD.org
COMMENT= OpenGL widgets library
USE_BZIP2= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig motif
USE_LDCONFIG= yes
USE_GL= gl
-USE_MOTIF= yes
USE_XORG= x11 xt xext
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --enable-motif
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index d1227a442d75..ebacb3489b8b 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -16,16 +16,14 @@ LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick \
cdf.0:${PORTSDIR}/science/cdf
USE_XORG= xinerama xext xpm xmu sm ice
-USES= bison
+USES= bison motif gmake
USE_GCC= any
USE_GL= yes
-USE_MOTIF= yes
USE_AUTOTOOLS= libtool
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV= ARCH="${OPSYS:L}"
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GMAKE= yes
NO_MTREE= yes
PLIST_SUB= ARCH=${OPSYS:L}
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/graphics/plotutils/Makefile b/graphics/plotutils/Makefile
index 403c7f4189a9..7e8b68d3c314 100644
--- a/graphics/plotutils/Makefile
+++ b/graphics/plotutils/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: plotutils
-# Date created: 19 June 1998
-# Whom: Chuck Robey (chuckr)
-#
+# Created by: Chuck Robey (chuckr)
# $FreeBSD$
-#
PORTNAME= plotutils
PORTVERSION= 2.6
@@ -13,11 +9,11 @@ CATEGORIES= graphics
MASTER_SITES= GNU
MAINTAINER= stephen@FreeBSD.org
-COMMENT= A plotting library and toolkit
+COMMENT= Plotting library and toolkit
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-USE_MOTIF= yes
+USES= motif
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --enable-libplotter --enable-libxmi --with-motif
USE_LDCONFIG= yes
diff --git a/graphics/white_dune/Makefile b/graphics/white_dune/Makefile
index a62f7bbc7443..07aad11935df 100644
--- a/graphics/white_dune/Makefile
+++ b/graphics/white_dune/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: white_dune
-# Date created: Apr 12, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= white_dune
PORTVERSION= ${DISTVERSION:S/pl/./}
@@ -23,8 +18,8 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= motif
USE_XORG= xft
-USE_MOTIF= yes
USE_GL= gl glu glut
USE_SDL= sdl
GNU_CONFIGURE= yes
diff --git a/graphics/xmfract/Makefile b/graphics/xmfract/Makefile
index 41d55f0d3209..c076199a7ba7 100644
--- a/graphics/xmfract/Makefile
+++ b/graphics/xmfract/Makefile
@@ -13,7 +13,7 @@ COMMENT= The dos based 'fractint' with an X/Motif front end
LICENSE= GPLv2
-USE_MOTIF= yes
+USES= motif
USE_AUTOTOOLS= aclocal autoconf
ACLOCAL_ARGS= # none
CONFIGURE_ARGS= --with-editres \
@@ -23,7 +23,7 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-IGNORE= fails to run with: XCreateImage failed
+BROKEN= fails to run with: XCreateImage failed
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index f8d7ea5b0adb..bc03b701c557 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -14,7 +14,7 @@ COMMENT= Display PDF files and convert them to other formats
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -57,7 +57,7 @@ MAN5= xpdfrc.5
.if ${PORT_OPTIONS:MX11}
CONFIGURE_ARGS+= --with-x
-USE_MOTIF= yes
+USES+= motif
MAN1+= xpdf.1
PLIST_SUB+= X11=""
.else