aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/dvi2ps/Makefile8
-rw-r--r--lang/cel/Makefile8
-rw-r--r--net/gopher/Makefile8
-rw-r--r--x11-wm/wmg/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/japanese/dvi2ps/Makefile b/japanese/dvi2ps/Makefile
index e2eeef936136..933e10c3da0a 100644
--- a/japanese/dvi2ps/Makefile
+++ b/japanese/dvi2ps/Makefile
@@ -19,6 +19,12 @@ LIB_DEPENDS= VFlib2.24:${PORTSDIR}/japanese/vflib
MAN1= dvi2ps.1
MANLANG= "" ja
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@(cd ${WRKSRC}; make newlib)
@@ -43,4 +49,4 @@ post-install:
)
@${SH} ${PKGREQ} ${PKGNAME} INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/cel/Makefile b/lang/cel/Makefile
index b72e3de9e30b..296b1787b279 100644
--- a/lang/cel/Makefile
+++ b/lang/cel/Makefile
@@ -21,6 +21,12 @@ DOCFILES= CoreArchitecture.html DefaultProtos Linker.html \
Logs.html ProtoLanguage.html README SimpleDataFormat.html \
Threads activation.html stackframe structure.html todo.html
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vm/cel ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -30,4 +36,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/gopher/Makefile b/net/gopher/Makefile
index b872012bf437..b8420f4924f1 100644
--- a/net/gopher/Makefile
+++ b/net/gopher/Makefile
@@ -21,8 +21,14 @@ MAN1= gopher.1 gophfilt.1
MAN5= gopherd.conf.5 gopherrc.5
MAN8= gopherd.8 gopherindex.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | xargs ${REINPLACE_CMD} -e \
's,<malloc.h>,<stdlib.h>,'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/wmg/Makefile b/x11-wm/wmg/Makefile
index a80e4e5d4bdd..25662d35cf99 100644
--- a/x11-wm/wmg/Makefile
+++ b/x11-wm/wmg/Makefile
@@ -22,4 +22,10 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>