aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/a2ps-letter/Makefile25
-rw-r--r--print/a2ps-letter/pkg-plist42
2 files changed, 43 insertions, 24 deletions
diff --git a/print/a2ps-letter/Makefile b/print/a2ps-letter/Makefile
index 17e8256a0394..b421a663c0da 100644
--- a/print/a2ps-letter/Makefile
+++ b/print/a2ps-letter/Makefile
@@ -54,13 +54,32 @@ CONFLICTS?= a2ps-a4-4.* a2ps-letter-4.*
.endif
.endif
-.if defined(WITH_EMACS)
+OPTIONS_DEFINE=NLS I18N EMACS
+OPTIONS_DEFAULT=NLS
+NO_OPTIONS_SORT=yes
+EMACS_DESC=Enable Emacs support
+I18N_DESC=Enable I18N support
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MEMACS}
+USE_EMACS= yes
+CONFIGURE_ARGS+= --with-lispdir=${LOCALBASE}/${EMACS_SITE_LISPDIR}
PLIST_SUB+= WITHEMACS=""
.else
+CONFIGURE_ENV+= EMACS=no
PLIST_SUB+= WITHEMACS="@comment "
.endif
-.if defined(WITH_I18N)
+.if ${PORT_OPTIONS:MI18N}
PLIST_SUB+= WITHI18N=""
pre-configure:
@@ -81,7 +100,7 @@ PLIST_SUB+= WITHI18N="@comment "
post-install:
${STRIP_CMD} ${PREFIX}/bin/a2ps
-.if defined(WITH_EMACS)
+.if ${PORT_OPTIONS:MEMACS}
${MKDIR} ${PREFIX}/lib/xemacs/site-lisp
${LN} -sf ${PREFIX}/share/emacs/site-lisp/a2ps-print.el \
${PREFIX}/lib/xemacs/site-lisp/a2ps-print.el
diff --git a/print/a2ps-letter/pkg-plist b/print/a2ps-letter/pkg-plist
index 7438ad0f71bc..2101bd94764b 100644
--- a/print/a2ps-letter/pkg-plist
+++ b/print/a2ps-letter/pkg-plist
@@ -259,27 +259,27 @@ lib/liba2ps.a
%%DATADIR%%/sheets/xs.ssh
%%DATADIR%%/sheets/yacc.ssh
%%DATADIR%%/sheets/zsh.ssh
-share/locale/ca/LC_MESSAGES/a2ps.mo
-share/locale/cs/LC_MESSAGES/a2ps.mo
-share/locale/da/LC_MESSAGES/a2ps.mo
-share/locale/de/LC_MESSAGES/a2ps.mo
-share/locale/es/LC_MESSAGES/a2ps.mo
-share/locale/et/LC_MESSAGES/a2ps.mo
-share/locale/fr/LC_MESSAGES/a2ps.mo
-share/locale/it/LC_MESSAGES/a2ps.mo
-share/locale/ko/LC_MESSAGES/a2ps.mo
-share/locale/nl/LC_MESSAGES/a2ps.mo
-share/locale/no/LC_MESSAGES/a2ps.mo
-share/locale/pl/LC_MESSAGES/a2ps.mo
-share/locale/pt/LC_MESSAGES/a2ps.mo
-share/locale/ru/LC_MESSAGES/a2ps.mo
-share/locale/sl/LC_MESSAGES/a2ps.mo
-share/locale/sv/LC_MESSAGES/a2ps.mo
-share/locale/tr/LC_MESSAGES/a2ps.mo
-%%WITHEMACS%%share/emacs/site-lisp/a2ps-print.el
-%%WITHEMACS%%share/emacs/site-lisp/a2ps.el
-%%WITHEMACS%%lib/xemacs/site-lisp/a2ps-print.el
-%%WITHEMACS%%lib/xemacs/site-lisp/a2ps.el
+%%NLS%%share/locale/ca/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/da/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/de/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/es/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/et/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/it/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/no/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/a2ps.mo
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps-print.el
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps-print.elc
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps.el
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps.elc
@dirrm %%DATADIR%%/ogonkify/fonts
@dirrm %%DATADIR%%/ogonkify/afm
@dirrm %%DATADIR%%/ogonkify