aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/libpwstor/Makefile56
-rw-r--r--security/libpwstor/distinfo3
-rw-r--r--security/libpwstor/pkg-descr13
4 files changed, 73 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3301e5535422..9e28e5633542 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -251,6 +251,7 @@
SUBDIR += libparanoia
SUBDIR += libprelude
SUBDIR += libpreludedb
+ SUBDIR += libpwstor
SUBDIR += libsectok
SUBDIR += libssh2
SUBDIR += libtasn1
diff --git a/security/libpwstor/Makefile b/security/libpwstor/Makefile
new file mode 100644
index 000000000000..77c938fa18c0
--- /dev/null
+++ b/security/libpwstor/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: libpwstor
+# Date created: 2008-10-23
+# Whom: Matt Harris <mattdharris@users.sourceforge.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpwstor
+PORTVERSION= 0.1
+CATEGORIES= security devel
+MASTER_SITES= SF/kageki
+
+MAINTAINER= mattdharris@users.sourceforge.net
+COMMENT= A password storage library for C programmers
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/pwtool \
+ include/pwstor.h \
+ lib/libpwstor.a \
+ lib/libpwstor.so \
+ lib/libpwstor.so.0.1
+
+MANCOMPESSED= no
+MAN1= pwtool.1
+MAN3= pwstor.3 \
+ pws_version.3 \
+ pws_version_int.3 \
+ pws_rand_get.3 \
+ pws_memnuke.3 \
+ pws_base64_encode.3 \
+ pws_base64_decode.3 \
+ pws_passwords_encode.3 \
+ pws_passwords_encodemulti.3 \
+ pws_passwords_len.3 \
+ pws_passwords_check.3 \
+ pws_passwords_checkmulti.3 \
+ pws_passwords_converttomulti.3
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+CFLAGS+= -fPIC -DPIC
+.endif
+
+.if ${OSVERSION} < 700000
+BROKEN= does not compile on FreeBSD 6.x
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/libpwstor/distinfo b/security/libpwstor/distinfo
new file mode 100644
index 000000000000..76faf3f16d08
--- /dev/null
+++ b/security/libpwstor/distinfo
@@ -0,0 +1,3 @@
+MD5 (libpwstor-0.1.tar.bz2) = af9651a27c94b78daff9db1f071dbc06
+SHA256 (libpwstor-0.1.tar.bz2) = 5cdc05d6e94cd97a87bc1cd98d330f6231faed9f38ab5d15c490140a18de5abf
+SIZE (libpwstor-0.1.tar.bz2) = 48583
diff --git a/security/libpwstor/pkg-descr b/security/libpwstor/pkg-descr
new file mode 100644
index 000000000000..a7ec00061942
--- /dev/null
+++ b/security/libpwstor/pkg-descr
@@ -0,0 +1,13 @@
+libpwstor is a library implementing a password storage format
+for C programmers. This format provides a reasonable level of
+security by utilizing SHA-256 in addition to a random salt to
+mitigate dictionary and rainbow table attacks.
+
+In addition to the core functionality, libpwstor also offers
+some additional functions such as Base64 encoding and decoding.
+All functionality is implemented and designed in such a way as
+to be easy to use for C programmers of varying skill levels,
+while preserving reasonable security in the underlying storage
+format.
+
+WWW: http://sourceforge.net/projects/kageki
aph'>* Implement a temporary patch that fixes coredumps under certaintobez2009-09-142-0/+12 * - Fix dependency to py-reportlabmiwi2009-09-051-1/+2 * Update to 1.3(0).tobez2009-09-012-4/+5 * - update to 0.36leeym2009-09-013-9/+10 * - fix dependencyclsung2009-08-311-0/+4 * Reset chinsan@FreeBSD.org due to numerous maintainer-timeouts and nolinimon2009-08-291-1/+1 * - Fix some more SF URLs, including ones in PATCH_SITES and comments (for cons...amdmi32009-08-281-2/+1 * - Update to 2.25clsung2009-08-262-5/+5 * Mark BROKEN with the new fribidi.marcus2009-08-261-0/+2 * Add a fribidi-config wrapper script around pkg-config to fix some oldermarcus2009-08-244-0/+36 * Add rcctoolsmakc2009-08-231-0/+1 * Add new port converters/rcctools:makc2009-08-233-0/+39 * Fix the build with fribidi-0.19.2.marcus2009-08-231-0/+3028 * Perl version of Python's URL-safe base64 codecmiwi2009-08-235-0/+40 * - Take over maintainershipmiwi2009-08-231-1/+1 * Chase the fribidi shared lib bump.marcus2009-08-232-2/+4 * Update to 0.19.2.marcus2009-08-233-21/+49 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-226-12/+6 * pisa is a html2pdf converter using the ReportLab Toolkit, themiwi2009-08-185-0/+129 * Fix with build with llvm/clang.marcus2009-08-164-0/+48 * Igbinary is a drop in replacement for the standard PHP serializer.miwi2009-08-144-0/+32 * Update to 0.005.tobez2009-08-132-4/+4 * - Update to 0.5.10rafan2009-08-093-10/+33 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-037-7/+7 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-313-3/+3 * Utilize %%SITE_PERL%% and %%PERL_ARCH%% in pkg-plistspgollucci2009-07-311-3/+3 * Add converters/p5-Encoding-FixLatin, a Perl module and a command-linetobez2009-07-295-0/+39 * - Update to 0.34pgollucci2009-07-242-4/+4 * - lang/perl5.6 is dead, remove PERL_LEVEL/PERL_VERSION < 500801 checkspgollucci2009-07-235-34/+5 * - Update to 2.35rafan2009-07-162-4/+4 * - Update to 2.1amdmi32009-07-152-7/+7 * - Update to 2.1amdmi32009-07-152-7/+11 * - Update to 2.1amdmi32009-07-153-50/+54 * - Update to 1.21clsung2009-07-072-4/+4 * Fix patch issue WITH_EXTRA_PATCHES.nork2009-07-052-1/+4 * Update to 1.13.1.marcus2009-07-053-13/+10 * - Update to 0.74pgollucci2009-07-042-4/+4 * - Fix build after djvulibre update (pthreads are required).stas2009-07-041-0/+1 * - djvulibre DSO version has changed to 22. Reflect this.stas2009-07-031-2/+2 * - Update to 0.63jadawin2009-06-292-4/+4 * - Update to 0.22pgollucci2009-06-172-5/+5 * - Assign all unmaintained ruby ports to ruby@,stas2009-06-162-2/+2 * - Update to 0.32pgollucci2009-06-162-4/+4 * - Fix build with custom PREFIX/LOCALBASEpgollucci2009-06-161-0/+3 * Fix the OPTIONS bit of EXTRA_PATCHES.kwm2009-06-151-2/+2 * Re-enable EXTRA_PATCHES.nork2009-06-152-7/+10 * Comment out the EXTRA_PATCHES option. Patch needs to be updated.kwm2009-06-151-9/+9 * Update to 1.13. Note: the iconv(1) utility is now licensed under GPLv3.marcus2009-06-156-36/+37 * Fix install with custom PREFIX.itetcu2009-06-151-0/+7 * scrappy's bit has been taken for safekeeping, so return these ports tolinimon2009-06-142-2/+2 * - Update to 3.08jadawin2009-06-112-4/+4 * - Add Backup mirrorsdhn2009-06-061-1/+2 * - Update to 0.73pgollucci2009-06-062-4/+6 * This port is a perl wrapper for bsdconv.miwi2009-06-065-0/+40 * This port is a php wrapper for bsdconv.miwi2009-06-064-0/+38 * BSD licensed charset/encoding converter library withmiwi2009-06-065-0/+77 * Upgrade to 2.15.kuriyama2009-06-042-4/+4 * Build libiconv with -std=gnu89.ed2009-06-041-0/+1 * String::SetUTF8 lets you directly set or unset the UTF-8 flagdhn2009-05-265-0/+40 * JSON (JavaScript Object Notation, http://json.org) is a lightweightmiwi2009-05-234-0/+43 * - Update to 0.60miwi2009-05-092-4/+4 * - New port: convertors/fpc-iconvencacm2009-05-043-0/+31 * - Update to 0.30chinsan2009-04-122-4/+4 * Presenting GNOME 2.26 for FreeBSD. Seemarcus2009-04-102-4/+4 * - Mark MAKE_JOBS_UNSAFEpav2009-04-081-0/+1 * Mark all my ports as MAKE_JOBS_SAFE and MAKE_JOBS_UNSAFEgarga2009-03-291-1/+2 * - Update to 2.33rafan2009-03-272-4/+4 * - Update to 0.29chinsan2009-03-232-4/+4 * - Update to 0.52amdmi32009-03-023-8/+6 * Upgrade to 2.14.kuriyama2009-02-262-4/+4 * - Update to 2.23.11 (2.2311)clsung2009-02-192-4/+4 * - Update to 2.31rafan2009-02-172-4/+4 * - Update to 2.30rafan2009-02-172-4/+4 * - Update to 2.29rafan2009-02-152-4/+7 * - Update to 2.231 (2.23.1)clsung2009-02-092-5/+5 * Perl extension for serialize/deserialize AMF0/AMF3 datajadawin2009-02-055-0/+42 * Update to 20090107 release.ale2009-02-012-7/+7 * - Update download locationspgollucci2009-02-011-0/+1 * - Update download location, mirror it in my public distfilespgollucci2009-02-011-1/+1 * - Update 1.19clsung2009-01-272-4/+4 * - Update to 2.27rafan2009-01-222-4/+4 * Update to 0.004.tobez2009-01-092-4/+4 * Update to 0.42,makc2009-01-041-5/+4 * - Update to 1.14lwhsu2009-01-023-11/+12 * Update to 0.27erwin2008-12-193-6/+55 * - Update to 0.6.2miwi2008-12-142-4/+4 * Update to 5.2.7 release.ale2008-12-071-1/+0 * - Update to 1.1.1miwi2008-12-073-21/+21 * - Update to 0.28chinsan2008-11-272-4/+4 * Add p5-JSON-XS-VersionOneAndTwo 0.31, support versions 1 and 2 ofskv2008-11-225-0/+39 * Svglib is an experimental library for reading SVG files and convertingmiwi2008-11-145-0/+36 * - Update to 1.12miwi2008-10-252-4/+4 * Upgrade to 0.04.kuriyama2008-10-182-6/+4 * - fix dependencyleeym2008-10-172-4/+5 * - use @dirrmtry instead of @dirrmleeym2008-10-171-15/+15 * zbase32 is a base32 encoder/decoder.It is an alternatemiwi2008-10-055-0/+55 * - Update to 1.4.5garga2008-10-012-4/+4 * - Update to 2.23clsung2008-09-292-4/+4 * Update to version 0.5201demon2008-09-232-4/+5 * Upgrade to 2.12 (and remove unneeded dependencies).kuriyama2008-09-082-8/+4 * Reset infofarmer due to maintainer-timeouts and no response to email.linimon2008-09-071-1/+1 * - Update to 0.7.8miwi2008-09-062-4/+4 * Update to 20080315.knu2008-09-022-4/+4 * - Fix build on amd64jadawin2008-09-023-13/+76 * - Update to 1.17clsung2008-08-292-5/+4 * - Update djvulibre to 3.5.21.stas2008-08-261-7/+2 * - Update to 0.4.12miwi2008-08-262-5/+4 * This is a standalone converter for the OpenOffice.org swriter (*.sxw,*.odt)amdmi32008-08-225-0/+64 * Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.rafan2008-08-217-8/+0 * - Update to 0.27chinsan2008-08-182-4/+4 * - Update to 0.26chinsan2008-08-102-4/+4 * - Update to 2.26rafan2008-07-202-5/+5 * - Update to 2.20miwi2008-07-202-4/+4 * Update to 0.25erwin2008-07-112-4/+4 * Upgrade to 2.11.kuriyama2008-07-023-4/+6 * First all, ahze did most of work. Thanks ahze! Last week or so, I am justmezz2008-07-011-1/+2 * - Update to 1.4.4garga2008-06-202-4/+4 * - Remove converters/compface, we already have this port on ports tree, see ma...lippe2008-06-185-45/+0 * Compface provides utilities and a library for converting tolippe2008-06-175-0/+45 * - update to 1.11leeym2008-06-162-5/+4 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-069-4/+9 * - Update to 0.71miwi2008-06-012-4/+4 * - Update to 1.01miwi2008-05-312-4/+4 * - Reassign to perl@tabthorpe2008-05-261-1/+1 * - Update to 2.25rafan2008-05-122-4/+4 * Update to 0.105.tobez2008-05-082-4/+4 * Update to 0.4.10itetcu2008-05-06