aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/i386-wine/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/emulators/i386-wine/Makefile b/emulators/i386-wine/Makefile
new file mode 100644
index 000000000000..3e65cfa1622b
--- /dev/null
+++ b/emulators/i386-wine/Makefile
@@ -0,0 +1,16 @@
+# Created by: David Naylor (dbn@FreeBSD.org)
+# $FreeBSD$
+
+# Special bootstrapper to allow:
+# - i386 specific port to be slave to ${PORTSDIR}/emulators/wine
+# - amd64 specific port to be normal port (based on binary package)
+
+.if !defined(ARCH)
+ARCH!= uname -p
+.endif
+
+.if ${ARCH} == i386
+.include "${.CURDIR}/Makefile.i386"
+.else
+.include "${.CURDIR}/Makefile.inc"
+.endif