aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/gphoto2/Makefile35
-rw-r--r--graphics/gthumb/Makefile40
-rw-r--r--graphics/libopenraw/Makefile20
-rw-r--r--mail/popular/Makefile16
-rw-r--r--x11-toolkits/gtkunique/Makefile20
5 files changed, 59 insertions, 72 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index e86fdcd76600..e4ae296bbcf5 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gphoto
-# Date created: 26 May 1999
-# Whom: Anders Nordby <anders@fix.no>
-#
+# Created by: Anders Nordby <anders@fix.no>
# $FreeBSD$
-#
PORTNAME= gphoto2
PORTVERSION= 2.4.14
@@ -13,11 +9,12 @@ MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION}
MAINTAINER= pav@FreeBSD.org
COMMENT= A command-line frontend to libgphoto2
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
+ gphoto2:${PORTSDIR}/graphics/libgphoto2
USE_BZIP2= yes
USE_GMAKE= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-cdk
MAKE_JOBS_SAFE= yes
@@ -27,23 +24,25 @@ MAN1= gphoto2.1
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-OPTIONS= AALIB "Enable command line capture preview (aalib)" on
+OPTIONS_DEFINE= AALIB DOCS NLS
+OPTIONS_DEFAULT= AALIB
+AALIB_DESC= Command line capture preview (aalib)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_AALIB)
-LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+.if ${PORT_OPTIONS:MAALIB}
+LIB_DEPENDS+= aa:${PORTSDIR}/graphics/aalib \
+ jpeg:${PORTSDIR}/graphics/jpeg
.else
CONFIGURE_ARGS+=--without-aalib --without-jpeg
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -51,10 +50,10 @@ post-patch:
s|-g -Wall||g' ${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
.for file in NEWS
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 666c64ad2cb0..ba833ef7f7c0 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gThumb2
-# Date created: 17 Aug 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gthumb
PORTVERSION= 2.14.1
@@ -25,6 +21,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedocutils gconf2
WANT_GSTREAMER= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -39,17 +36,18 @@ GCONF_SCHEMAS= gthumb.schemas gthumb-comments.schemas gthumb-file-manager.schema
PLIST_SUB= GTHUMB_VER=2.14
-OPTIONS= EXIV2 "Exif support (image metadata)" On \
- CLUTTER "Fancy slideshows" On \
- GSTREAMER "Video playback" On \
- OPENRAW "Support for camera RAW files" On \
- SOUP "Web services uploaders" On \
- BRASERO "Write galleries to CD/DVD (large dependency)" On \
- YELP "Viewer for built-in help system" On
+OPTIONS_DEFINE= EXIV2 CLUTTER GSTREAMER OPENRAW SOUP BRASERO YELP
+OPTIONS_DEFAULT= EXVI2 CLUTTER GSTREAMER OPENRAW SOUP BRASERO YELP
+CLUTTER_DESC= Fancy slideshows
+GSTREAMER_DESC= Video playback
+OPENRAW_DESC= Support for camera RAW files
+SOUP_DESC= Web services uploaders
+BRASERO_DESC= Write galleries to CD/DVD (large dependency)
+YELP_DESC= Viewer for built-in help system
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_EXIV2)
+.if ${PORT_OPTIONS:MEXIV2}
LIB_DEPENDS+= exiv2.12:${PORTSDIR}/graphics/exiv2
CONFIGURE_ARGS+=--enable-exiv2
PLIST_SUB+= EXIV2=""
@@ -58,14 +56,14 @@ CONFIGURE_ARGS+=--disable-exiv2
PLIST_SUB+= EXIV2="@comment "
.endif
-.if defined(WITH_CLUTTER)
+.if ${PORT_OPTIONS:MCLUTTER}
LIB_DEPENDS+= clutter-gtk-0.10.0:${PORTSDIR}/graphics/clutter-gtk
CONFIGURE_ARGS+=--enable-clutter
.else
CONFIGURE_ARGS+=--disable-clutter
.endif
-.if defined(WITH_GSTREAMER)
+.if ${PORT_OPTIONS:MGSTREAMER}
USE_GSTREAMER= yes
CONFIGURE_ARGS+=--enable-gstreamer
PLIST_SUB+= GSTREAMER=""
@@ -75,14 +73,14 @@ CONFIGURE_ARGS+=--disable-gstreamer
PLIST_SUB+= GSTREAMER="@comment "
.endif
-.if defined(WITH_OPENRAW)
+.if ${PORT_OPTIONS:MOPENRAW}
LIB_DEPENDS+= openrawgnome.6:${PORTSDIR}/graphics/libopenraw
CONFIGURE_ARGS+=--enable-libopenraw
.else
CONFIGURE_ARGS+=--disable-libopenraw
.endif
-.if defined(WITH_SOUP)
+.if ${PORT_OPTIONS:MSOUP}
LIB_DEPENDS+= soup-gnome-2.4.1:${PORTSDIR}/devel/libsoup-gnome
CONFIGURE_ARGS+=--enable-libsoup --enable-gnome-keyring
PLIST_SUB+= SOUP=""
@@ -92,7 +90,7 @@ CONFIGURE_ARGS+=--disable-libsoup --disable-gnome-keyring
PLIST_SUB+= SOUP="@comment "
.endif
-.if defined(WITH_BRASERO)
+.if ${PORT_OPTIONS:MBRASERO}
LIB_DEPENDS+= brasero-burn.3:${PORTSDIR}/sysutils/brasero
CONFIGURE_ARGS+=--enable-libbrasero
PLIST_SUB+= BRASERO=""
@@ -101,8 +99,8 @@ CONFIGURE_ARGS+=--disable-libbrasero
PLIST_SUB+= BRASERO="@comment "
.endif
-.if defined(WITH_YELP)
+.if ${PORT_OPTIONS:MYELP}
RUN_DEPENDS+= yelp:${PORTSDIR}/x11/yelp
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/libopenraw/Makefile b/graphics/libopenraw/Makefile
index 45544309a9db..272dd1a8cfc6 100644
--- a/graphics/libopenraw/Makefile
+++ b/graphics/libopenraw/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libopenraw
-# Date created: 21 Mar 2007
-# Whom: Pav Lucistnik <pav@FreeBSD.org>
-#
+# Created by: Pav Lucistnik <pav@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libopenraw
PORTVERSION= 0.0.8
@@ -20,16 +16,18 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
MAKE_JOBS_SAFE= yes
USE_GNOME= libxml2
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-boost=${LOCALBASE}/include
-OPTIONS= GNOME "GNOME support (needs gtk20)" on
+OPTIONS_DEFINE= GNOME
+OPTIONS_DEFAULT= GNOME
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_GNOME)
+.if ${PORT_OPTIONS:MGNOME}
USE_GNOME= gtk20
PLIST_SUB+= GNOME=""
.else
@@ -37,12 +35,8 @@ CONFIGURE_ARGS+=--disable-gnome
PLIST_SUB+= GNOME="@comment "
.endif
-.if ${OSVERSION} < 700000
-BROKEN= does not configure on 6.X
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|testsuite ||' ${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/popular/Makefile b/mail/popular/Makefile
index f12a9e558142..760da5fc9cc0 100644
--- a/mail/popular/Makefile
+++ b/mail/popular/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: popular
-# Date created: 11 July 2005
-# Whom: Pav Lucistnik <pav@FreeBSD.org>
-#
+# Created by: Pav Lucistnik <pav@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= popular
PORTVERSION= 1.5.5
@@ -35,11 +31,13 @@ MAN1= pcheck.1 pcontrol.1 pdeliver.1 pstatus.1 ptestpdm.1
MAN7= popular-log.7
MAN8= pcheckd.8 pproxy.8 pserv.8 ringd.8
-OPTIONS= DB4 "Build db4 pdm module" on
+OPTIONS_DEFINE= DB4
+OPTIONS_DEFAULT= DB4
+DB4_DESC= Build db4 pdm module
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_DB4)
+.if ${PORT_OPTIONS:MDB4}
LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
PLIST_SUB+= WITH_DB4=""
PDM_MODULES+= db4
@@ -54,4 +52,4 @@ post-install:
${MKDIR} ${PREFIX}/include/popular
${FIND} ${WRKSRC}/src -name *.h | ${XARGS} -n 1 -J % ${INSTALL_DATA} % ${PREFIX}/include/popular
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtkunique/Makefile b/x11-toolkits/gtkunique/Makefile
index 4c6f5f851f3d..6bd0659f3de9 100644
--- a/x11-toolkits/gtkunique/Makefile
+++ b/x11-toolkits/gtkunique/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: GtkUnique
-# Date created: 21 Mar 2007
-# Whom: Pav Lucistnik <pav@FreeBSD.org>
-#
+# Created by: Pav Lucistnik <pav@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gtkunique
PORTVERSION= 0.9.1
@@ -20,23 +16,25 @@ USE_AUTOTOOLS= libtool
USE_GETTEXT= yes
USE_GNOME= gtk20 ltverhack
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= DBUS "D-Bus backend" on
+OPTIONS_DEFINE= DBUS
+OPTIONS_DEFAULT= DBUS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_DBUS)
-PLIST_SUB+= DBUS="@comment " XLIBS=""
-.else
+.if ${PORT_OPTIONS:MDBUS}
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
PLIST_SUB+= DBUS="" XLIBS="@comment "
+.else
+PLIST_SUB+= DBUS="@comment " XLIBS=""
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-Werror ||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>