aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/portmk/Makefile4
-rw-r--r--ports-mgmt/portaudit/pkg-req5
-rw-r--r--ports-mgmt/portmk/Makefile4
-rw-r--r--security/portaudit/pkg-req5
4 files changed, 18 insertions, 0 deletions
diff --git a/devel/portmk/Makefile b/devel/portmk/Makefile
index 13cf2429e33c..27d9ee000628 100644
--- a/devel/portmk/Makefile
+++ b/devel/portmk/Makefile
@@ -47,6 +47,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
activate:
+ @if [ "`${ECHO_CMD} FreeBSD | ${TR} -s .`" != "FreeBSD" ]; then \
+ ${ECHO_MSG} "tr(1) is broken."; \
+ ${FALSE}; \
+ fi
@${GREP} -qs PORTMK /usr/share/mk/bsd.port.mk || \
${PATCH} -s -N -d /usr/share/mk -i ${PORTMK_PATCH} && \
${ECHO_MSG} ">> Configured bsd.port.mk."
diff --git a/ports-mgmt/portaudit/pkg-req b/ports-mgmt/portaudit/pkg-req
index c566a36bb3b6..5a8ba2d087db 100644
--- a/ports-mgmt/portaudit/pkg-req
+++ b/ports-mgmt/portaudit/pkg-req
@@ -23,5 +23,10 @@ INSTALL)
echo "${PKG_INFO} is too old, please update port sysutils/pkg_install-devel"
exit 1
fi
+
+ if [ "`echo FreeBSD | tr -s .`" != "FreeBSD" ]; then
+ echo "tr(1) is broken."
+ exit 1
+ fi
;;
esac
diff --git a/ports-mgmt/portmk/Makefile b/ports-mgmt/portmk/Makefile
index 13cf2429e33c..27d9ee000628 100644
--- a/ports-mgmt/portmk/Makefile
+++ b/ports-mgmt/portmk/Makefile
@@ -47,6 +47,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
activate:
+ @if [ "`${ECHO_CMD} FreeBSD | ${TR} -s .`" != "FreeBSD" ]; then \
+ ${ECHO_MSG} "tr(1) is broken."; \
+ ${FALSE}; \
+ fi
@${GREP} -qs PORTMK /usr/share/mk/bsd.port.mk || \
${PATCH} -s -N -d /usr/share/mk -i ${PORTMK_PATCH} && \
${ECHO_MSG} ">> Configured bsd.port.mk."
diff --git a/security/portaudit/pkg-req b/security/portaudit/pkg-req
index c566a36bb3b6..5a8ba2d087db 100644
--- a/security/portaudit/pkg-req
+++ b/security/portaudit/pkg-req
@@ -23,5 +23,10 @@ INSTALL)
echo "${PKG_INFO} is too old, please update port sysutils/pkg_install-devel"
exit 1
fi
+
+ if [ "`echo FreeBSD | tr -s .`" != "FreeBSD" ]; then
+ echo "tr(1) is broken."
+ exit 1
+ fi
;;
esac