aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/tuareg-mode.el/Makefile5
-rw-r--r--mail/rmime/Makefile4
2 files changed, 4 insertions, 5 deletions
diff --git a/lang/tuareg-mode.el/Makefile b/lang/tuareg-mode.el/Makefile
index 9845d62059c8..7e3c4509c25e 100644
--- a/lang/tuareg-mode.el/Makefile
+++ b/lang/tuareg-mode.el/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= http://www-rocq.inria.fr/~acohen/tuareg/mode/
MAINTAINER= dd@FreeBSD.org
COMMENT= Emacs major mode for editing Caml code
-BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
-RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
+EMACS_PORT_NAME?= emacs20
DOC_FILES= README HISTORY append-tuareg.el custom-tuareg.el
DOC_DIR= share/doc/tuareg-mode
@@ -30,7 +29,7 @@ do-build:
.for __f in ${ELISP_FILES}
cd ${WRKSRC} && echo '(setq load-path (cons "." load-path)) \
(batch-byte-compile)' | \
- emacs -batch -q -l /dev/stdin ${__f} 2> /dev/null
+ ${EMACS_CMD} -batch -q -l /dev/stdin ${__f} 2> /dev/null
.endfor
do-install:
diff --git a/mail/rmime/Makefile b/mail/rmime/Makefile
index f60b10da973b..8c9d44172ca1 100644
--- a/mail/rmime/Makefile
+++ b/mail/rmime/Makefile
@@ -19,7 +19,7 @@ EXTRACT_ONLY= # empty
MAINTAINER= dd@FreeBSD.org
COMMENT= Decode MIME messages inside Emacs (works with RMAIL, VM, and mh-e)
-BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
+EMACS_PORT_NAME?= emacs20
RUN_DEPENDS= metamail:${PORTSDIR}/mail/metamail
NO_WRKSUBDIR= yes
@@ -27,7 +27,7 @@ STRIP= # empty
do-build:
${CP} ${DISTDIR}/rmime.el ${WRKDIR}
- emacs -batch -f batch-byte-compile ${WRKDIR}/rmime.el
+ ${EMACS_CMD} -batch -f batch-byte-compile ${WRKDIR}/rmime.el
do-install:
${INSTALL_DATA} ${WRKDIR}/rmime.el ${WRKDIR}/rmime.elc\