aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt5
-rw-r--r--emulators/tpm-emulator/pkg-plist8
2 files changed, 7 insertions, 6 deletions
diff --git a/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt b/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt
index f264de37e902..fbf9772ab842 100644
--- a/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt
+++ b/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt
@@ -1,12 +1,13 @@
--- tddl/CMakeLists.txt.orig 2010-07-06 06:21:20.000000000 +0900
-+++ tddl/CMakeLists.txt 2010-10-25 02:56:43.620555878 +0900
++++ tddl/CMakeLists.txt 2010-12-11 04:00:11.868033375 +0900
@@ -5,18 +5,21 @@
set(tddl_SRCS "tddl.c" "tddl.h")
add_library(tddl SHARED ${tddl_SRCS})
+add_library(tddlStatic STATIC ${tddl_SRCS})
if(UNIX)
- set_target_properties(tddl PROPERTIES SOVERSION "1.2"
+- set_target_properties(tddl PROPERTIES SOVERSION "1.2"
++ set_target_properties(tddl PROPERTIES SOVERSION "1"
VERSION "1.2.${${PROJECT_NAME}_VERSION_MAJOR}.${${PROJECT_NAME}_VERSION_MINOR}")
+ set_target_properties(tddlStatic PROPERTIES OUTPUT_NAME tddl)
elseif(WIN32)
diff --git a/emulators/tpm-emulator/pkg-plist b/emulators/tpm-emulator/pkg-plist
index 3df67320317a..180b7f011d9c 100644
--- a/emulators/tpm-emulator/pkg-plist
+++ b/emulators/tpm-emulator/pkg-plist
@@ -1,8 +1,8 @@
+bin/tpmd
include/tddl.h
-lib/libtddl.so.1.2.0.7
-lib/libtddl.so.1.2
-lib/libtddl.so
lib/libtddl.a
-bin/tpmd
+lib/libtddl.so
+lib/libtddl.so.1
+lib/libtddl.so.1.2.0.7
@unexec rm -f /var/tpm/tpmd_socket*
@unexec rm -rf /var/tpm