aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/cfengine35/Makefile2
-rw-r--r--sysutils/cfengine35/files/patch-libpromises-expand.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/cfengine35/Makefile b/sysutils/cfengine35/Makefile
index c012548bd3d8..f436145e6b7d 100644
--- a/sysutils/cfengine35/Makefile
+++ b/sysutils/cfengine35/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cfengine
PORTVERSION= 3.5.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://cfengine.com/source-code/download?file=
diff --git a/sysutils/cfengine35/files/patch-libpromises-expand.c b/sysutils/cfengine35/files/patch-libpromises-expand.c
new file mode 100644
index 000000000000..49890fdd3813
--- /dev/null
+++ b/sysutils/cfengine35/files/patch-libpromises-expand.c
@@ -0,0 +1,10 @@
+--- libpromises/expand.c.orig 2014-03-31 18:24:39.000000000 +0000
++++ libpromises/expand.c 2014-03-31 18:25:10.000000000 +0000
+@@ -787,6 +787,7 @@
+ ScopeNewSpecial(ctx, "this", "promise_linenumber", number, DATA_TYPE_STRING);
+ }
+
++ ScopeNewSpecial(ctx, "this", "promiser", pp->promiser, DATA_TYPE_STRING);
+ snprintf(v, CF_MAXVARSIZE, "%d", (int) getuid());
+ ScopeNewSpecial(ctx, "this", "promiser_uid", v, DATA_TYPE_INT);
+ snprintf(v, CF_MAXVARSIZE, "%d", (int) getgid());