aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CVSROOT/modules1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/nogger/Makefile39
-rw-r--r--audio/nogger/distinfo1
-rw-r--r--audio/nogger/files/patch-Makefile10
-rw-r--r--audio/nogger/pkg-comment1
-rw-r--r--audio/nogger/pkg-descr4
7 files changed, 57 insertions, 0 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index 46aa78428a35..c672c19dc1d2 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -4779,6 +4779,7 @@ noattach ports/mail/noattach
nocc ports/mail/nocc
nocol ports/net/nocol
nofgpg ports/security/nofgpg
+nogger ports/audio/nogger
nohup src/usr.bin/nohup
noip ports/net/noip
nologin src/sbin/nologin
diff --git a/audio/Makefile b/audio/Makefile
index 809be21a4177..d610f9b6dabe 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -161,6 +161,7 @@
SUBDIR += mziq
SUBDIR += napster
SUBDIR += nas
+ SUBDIR += nogger
SUBDIR += normalize
SUBDIR += nosefart
SUBDIR += nspmod
diff --git a/audio/nogger/Makefile b/audio/nogger/Makefile
new file mode 100644
index 000000000000..640fe202fb56
--- /dev/null
+++ b/audio/nogger/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: nogger
+# Date created: 2002-10-27
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= nogger
+PORTVERSION= 0.8.2
+CATEGORIES= audio
+MASTER_SITES= http://www.efd.lth.se/~d00jkr/nogger/
+
+MAINTAINER= trevor@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ vorbis.2:${PORTSDIR}/audio/libvorbis
+
+PLIST= ${WRKDIR}/plist
+USE_GMAKE= y
+ALL_TARGET= nogger
+
+pre-install:
+ ${ECHO_CMD} bin/nogger > ${PLIST}
+.ifndef(NOPORTDOCS)
+.for ii in COPYING README Thanks
+ ${ECHO_CMD} share/doc/nogger/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nogger ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for ii in COPYING README Thanks
+ ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/nogger/distinfo b/audio/nogger/distinfo
new file mode 100644
index 000000000000..ed84699a1732
--- /dev/null
+++ b/audio/nogger/distinfo
@@ -0,0 +1 @@
+MD5 (nogger-0.8.2.tar.gz) = cc300875f84fb36646b0faa31f263c31
diff --git a/audio/nogger/files/patch-Makefile b/audio/nogger/files/patch-Makefile
new file mode 100644
index 000000000000..da0a9dc4ce67
--- /dev/null
+++ b/audio/nogger/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Mon Oct 14 06:54:50 2002
++++ Makefile Sun Oct 27 12:33:42 2002
+@@ -2,7 +2,6 @@
+ NAME = nogger
+ VERSION = 0.8.2
+ DESTDIR = /usr
+-CC? = gcc
+ CFLAGS += `pkg-config --cflags gtk+-2.0` -D_VERSION=\"$(VERSION)\" \
+ -Wall -g
+ LDFLAGS = `pkg-config --libs gtk+-2.0 --libs gthread-2.0` -lvorbis \
diff --git a/audio/nogger/pkg-comment b/audio/nogger/pkg-comment
new file mode 100644
index 000000000000..cafd00cb4965
--- /dev/null
+++ b/audio/nogger/pkg-comment
@@ -0,0 +1 @@
+No-frills, GTK-based Ogg Vorbis player
diff --git a/audio/nogger/pkg-descr b/audio/nogger/pkg-descr
new file mode 100644
index 000000000000..8fadc06c5a4c
--- /dev/null
+++ b/audio/nogger/pkg-descr
@@ -0,0 +1,4 @@
+Nogger is a no-frills, GTK-based Ogg Vorbis player. It only works
+with files, not streams.
+
+WWW: http://www.efd.lth.se/~d00jkr/nogger/nogger.txt