aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/clamav-devel/Makefile9
-rw-r--r--security/clamav-devel/distinfo4
-rw-r--r--security/clamav-devel/files/patch-unit_tests-check_common_sh24
3 files changed, 31 insertions, 6 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 171a5640ca97..fcdb2d50b333 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clamav
-PORTVERSION= 20110223
+PORTVERSION= 20110704
CATEGORIES= security
MASTER_SITES= http://www.clamav.net/snapshot/ \
LOCAL/garga/clamav-devel
@@ -32,6 +32,7 @@ OPTIONS= ARC "Enable arch archives support" On \
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+USE_GMAKE= yes
USE_RC_SUBR= clamav-clamd clamav-freshclam
CLAM_CONF_FILES= clamd freshclam
@@ -68,7 +69,8 @@ LDFLAGS+= -L${LOCALBASE}/lib \
# force to use -lthr until it's not fixed.
PTHREAD_LIBS= -lthr
-MAN1= clamconf.1 \
+MAN1= clambc.1 \
+ clamconf.1 \
clamscan.1 \
freshclam.1 \
sigtool.1 \
@@ -147,7 +149,6 @@ CONFIGURE_ARGS+=--without-iconv
.if (defined(WITH_LLVM) || defined(WITH_LLVM_PORTS)) && ( ${ARCH} == "i386" || ${ARCH} == "amd64" )
CONFIGURE_ARGS+=--enable-llvm
-USE_GMAKE= yes
. if defined(WITH_LLVM_PORTS)
BUILD_DEPENDS+= llvm-config:${PORTSDIR}/devel/llvm
CONFIGURE_ARGS+=--with-system-llvm=${LOCALBASE}/bin/llvm-config
@@ -228,7 +229,7 @@ pre-configure:
.if defined(WITH_TESTS) && ${OSVERSION} >= 700000
post-build:
@if [ ! -f "${PY_NO_THREAD}" ]; then \
- ${MAKE} -C ${WRKSRC} check; \
+ ${GMAKE} -C ${WRKSRC} check; \
fi
.endif
diff --git a/security/clamav-devel/distinfo b/security/clamav-devel/distinfo
index 112cfbafd6c1..b256c6e21ac0 100644
--- a/security/clamav-devel/distinfo
+++ b/security/clamav-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clamav-devel-20110223.tar.gz) = 01b8f78e530b30d864568897412c3f1671bc94e82f537a6fbb0694360cdeab79
-SIZE (clamav-devel-20110223.tar.gz) = 36780971
+SHA256 (clamav-devel-20110704.tar.gz) = 3a895f434ec6fc87f6a66a2601ba2cecbf45ab685d118743bbf438fce9d8a63f
+SIZE (clamav-devel-20110704.tar.gz) = 36869288
diff --git a/security/clamav-devel/files/patch-unit_tests-check_common_sh b/security/clamav-devel/files/patch-unit_tests-check_common_sh
new file mode 100644
index 000000000000..6bc88a25792c
--- /dev/null
+++ b/security/clamav-devel/files/patch-unit_tests-check_common_sh
@@ -0,0 +1,24 @@
+$RANDOM is a bashism, it has been replaced with portable code.
+
+Also, the randomly generated port is checked to make sure it's not already
+in use.
+
+--- unit_tests/check_common.sh.orig 2011-05-13 12:25:31.000000000 +0100
++++ unit_tests/check_common.sh 2011-06-28 19:12:00.683905036 +0100
+@@ -58,9 +58,13 @@
+ aa15bcf478d165efd2065190eb473bcb:544:ClamAV-Test-File
+ EOF
+ port=331$1
+- if test "x$RANDOM" != "x"; then
+- port=1`expr 100 + \( $RANDOM % 899 \)`$1
+- fi
++ tries=0
++ while nc -z localhost $port 2>/dev/null
++ do rand=` ( echo $$ ; time ps 2>&1 ; date ) | cksum | cut -f1 -d" " `
++ port=1`expr 100 + \( $rand % 899 \)`$1
++ [ $tries -gt 100 ] && echo Giving up, too many ports open && exit 1
++ tries=`expr $tries + 1`
++ done
+ cat <<EOF >test-clamd.conf
+ LogFile `pwd`/clamd-test.log
+ LogFileMaxSize 0