aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/reminiscence/Makefile4
-rw-r--r--games/reminiscence/distinfo6
-rw-r--r--games/reminiscence/files/patch-Makefile16
3 files changed, 14 insertions, 12 deletions
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index b3963b5896f7..9538c7a03a47 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= REminiscence
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
CATEGORIES= games
MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
- http://mirror.amdmi3.ru/distfiles/
+ https://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Rewritten engine for Flashback
diff --git a/games/reminiscence/distinfo b/games/reminiscence/distinfo
index 3c81864884e8..99fa068a31d1 100644
--- a/games/reminiscence/distinfo
+++ b/games/reminiscence/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497005474
-SHA256 (REminiscence-0.3.3.tar.bz2) = dea16f19d35fc4a75d15b9e987b54d11eccb2f6c211950c939d05bc8d7c0d9e2
-SIZE (REminiscence-0.3.3.tar.bz2) = 113533
+TIMESTAMP = 1510056549
+SHA256 (REminiscence-0.3.4.tar.bz2) = d389fe2fc4ec151dc072aac98c94333972c0cd37d9109994bc845167074e3913
+SIZE (REminiscence-0.3.4.tar.bz2) = 114004
diff --git a/games/reminiscence/files/patch-Makefile b/games/reminiscence/files/patch-Makefile
index fc66cca5397e..72a82eb8606f 100644
--- a/games/reminiscence/files/patch-Makefile
+++ b/games/reminiscence/files/patch-Makefile
@@ -1,19 +1,21 @@
---- Makefile.orig 2017-04-01 06:34:29 UTC
+--- Makefile.orig 2017-11-01 12:18:57 UTC
+++ Makefile
-@@ -2,11 +2,13 @@
+@@ -2,12 +2,13 @@
SDL_CFLAGS := `sdl2-config --cflags`
SDL_LIBS := `sdl2-config --libs`
+-DL_LIBS := -ldl
-MODPLUG_LIBS := -lmodplug
-TREMOR_LIBS := -lvorbisidec -logg
+-ZLIB_LIBS := -lz
+MODPLUG_CFLAGS := `pkg-config --cflags libmodplug`
-+MODPLUG_LIBS := `pkg-config --libs libmodplug`
-+TREMOR_CFLAGS := `pkg-config --cflags vorbisidec`
-+TREMOR_LIBS := `pkg-config --libs vorbisidec`
- ZLIB_LIBS := -lz
++MODPLUG_LIBS := `pkg-config --libs libmodplug`
++TREMOR_CFLAGS := `pkg-config --cflags vorbisidec`
++TREMOR_LIBS := `pkg-config --libs vorbisidec`
++ZLIB_LIBS := -lz
-CXXFLAGS += -Wall -MMD $(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
+CXXFLAGS += -Wall -MMD $(SDL_CFLAGS) $(MODPLUG_CFLAGS) $(TREMOR_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
- SRCS = collision.cpp cutscene.cpp file.cpp fs.cpp game.cpp graphics.cpp main.cpp menu.cpp \
+ SRCS = collision.cpp cutscene.cpp dynlib.cpp file.cpp fs.cpp game.cpp graphics.cpp main.cpp menu.cpp \
mixer.cpp mod_player.cpp ogg_player.cpp piege.cpp resource.cpp resource_aba.cpp \