aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/firefox-devel/Makefile4
-rw-r--r--www/firefox-devel/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/firefox-esr/Makefile4
-rw-r--r--www/firefox-esr/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/firefox/Makefile4
-rw-r--r--www/firefox/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/firefox10/Makefile4
-rw-r--r--www/firefox10/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/firefox15/Makefile4
-rw-r--r--www/firefox15/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/firefox3-devel/Makefile4
-rw-r--r--www/firefox3-devel/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/firefox35/Makefile4
-rw-r--r--www/firefox35/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/firefox36/Makefile4
-rw-r--r--www/firefox36/files/extra-patch-config_make-jars.pl10
-rw-r--r--www/flock/Makefile4
-rw-r--r--www/flock/files/extra-patch-config_make-jars.pl10
18 files changed, 126 insertions, 0 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox-devel/files/extra-patch-config_make-jars.pl b/www/firefox-devel/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox-devel/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox-esr/files/extra-patch-config_make-jars.pl b/www/firefox-esr/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox-esr/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox/files/extra-patch-config_make-jars.pl b/www/firefox/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox10/files/extra-patch-config_make-jars.pl b/www/firefox10/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox10/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox15/files/extra-patch-config_make-jars.pl b/www/firefox15/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox15/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox3-devel/files/extra-patch-config_make-jars.pl b/www/firefox3-devel/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox3-devel/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox35/files/extra-patch-config_make-jars.pl b/www/firefox35/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox35/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/firefox36/files/extra-patch-config_make-jars.pl b/www/firefox36/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/firefox36/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+
diff --git a/www/flock/Makefile b/www/flock/Makefile
index d93b0795a297..fa578292843e 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -100,6 +100,10 @@ EXTRA_SCRIPTS= ${PORTNAME}.rb
IGNORE= "core dumps on alpha during post-build"
.endif
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif
+
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
diff --git a/www/flock/files/extra-patch-config_make-jars.pl b/www/flock/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/www/flock/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+