aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-MySQL/Makefile27
-rw-r--r--devel/p5-Config-MySQL/distinfo2
-rw-r--r--devel/p5-Config-MySQL/pkg-descr7
-rw-r--r--devel/p5-Config-MySQL/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 76cafd4b2e2a..7b72d620414a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1467,6 +1467,7 @@
SUBDIR += p5-Config-MVP
SUBDIR += p5-Config-MVP-Reader-INI
SUBDIR += p5-Config-Model
+ SUBDIR += p5-Config-MySQL
SUBDIR += p5-Config-Objective
SUBDIR += p5-Config-Options
SUBDIR += p5-Config-Perl-V
diff --git a/devel/p5-Config-MySQL/Makefile b/devel/p5-Config-MySQL/Makefile
new file mode 100644
index 000000000000..f86848e18790
--- /dev/null
+++ b/devel/p5-Config-MySQL/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Config::MySQL
+# Date created: 19 Mar 2012
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-MySQL
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to read/write MySQL-style configuration files
+
+RUN_DEPENDS= \
+ p5-Config-INI>0:${PORTSDIR}/devel/p5-Config-INI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Config::MySQL.3 \
+ Config::MySQL::Reader.3 \
+ Config::MySQL::Writer.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-MySQL/distinfo b/devel/p5-Config-MySQL/distinfo
new file mode 100644
index 000000000000..e2a28fef76e6
--- /dev/null
+++ b/devel/p5-Config-MySQL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Config-MySQL-0.02.tar.gz) = db3c67c935aa8c1439f8e67ae7320753e1cf43587736d230e38c75c3106c7a1e
+SIZE (Config-MySQL-0.02.tar.gz) = 17287
diff --git a/devel/p5-Config-MySQL/pkg-descr b/devel/p5-Config-MySQL/pkg-descr
new file mode 100644
index 000000000000..0f14e7ce189e
--- /dev/null
+++ b/devel/p5-Config-MySQL/pkg-descr
@@ -0,0 +1,7 @@
+This module extends Config::INI to support reading and writing
+MySQL-style configuration files. Although deceptively similar to
+standard .INI files, they can include bare boolean options with no
+value assignment and additional features like !include and
+!includedir.
+
+WWW: http://search.cpan.org/dist/Config-MySQL/
diff --git a/devel/p5-Config-MySQL/pkg-plist b/devel/p5-Config-MySQL/pkg-plist
new file mode 100644
index 000000000000..105338935014
--- /dev/null
+++ b/devel/p5-Config-MySQL/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/MySQL/.packlist
+%%SITE_PERL%%/Config/MySQL.pm
+%%SITE_PERL%%/Config/MySQL/Reader.pm
+%%SITE_PERL%%/Config/MySQL/Writer.pm
+@dirrm %%SITE_PERL%%/Config/MySQL
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/MySQL