aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/alpng/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/alpng/Makefile b/graphics/alpng/Makefile
index be40b14ce293..e29e3b3459bb 100644
--- a/graphics/alpng/Makefile
+++ b/graphics/alpng/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: graphics/alpng
-# Date created: 27 Aug 2009
-# Whom: Stas Timokhin <stast@bsdportal.ru>
-#
+# Created by: Stas Timokhin <stast@bsdportal.ru>
# $FreeBSD$
-#
PORTNAME= alpng
PORTVERSION= 1.3
@@ -20,12 +16,16 @@ LIB_DEPENDS+= alleg:${PORTSDIR}/devel/allegro
HAS_CONFIGURE= yes
WRKSRC= ${WRKDIR}
MAKEFILE= makefile
-USE_GMAKE= yes
+USES= gmake
+MAKE_ARGS= CC=${CC}
CFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= include/alpng.h \
lib/libalpng.a
+do-configure:
+ @${REINPLACE_CMD} -e "s/gcc/${CC}/g" ${WRKSRC}/makefile
+
do-install:
${INSTALL_DATA} ${WRKSRC}/libalpng.a ${PREFIX}/lib/libalpng.a
${INSTALL_DATA} ${WRKSRC}/src/alpng.h ${PREFIX}/include/alpng.h