aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-attempt/Makefile20
-rw-r--r--devel/hs-attempt/distinfo2
-rw-r--r--devel/hs-attempt/pkg-descr4
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bac255d0d039..c42faae86e21 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -588,6 +588,7 @@
SUBDIR += hs-ansi-wl-pprint
SUBDIR += hs-arrows
SUBDIR += hs-asn1-data
+ SUBDIR += hs-attempt
SUBDIR += hs-base-unicode-symbols
SUBDIR += hs-base16-bytestring
SUBDIR += hs-base64-bytestring
diff --git a/devel/hs-attempt/Makefile b/devel/hs-attempt/Makefile
new file mode 100644
index 000000000000..25272400d78b
--- /dev/null
+++ b/devel/hs-attempt/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-attempt
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= attempt
+PORTVERSION= 0.3.1.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Data type for handling exceptions as failures
+
+LICENSE= BSD
+
+USE_CABAL= failure>=0.1.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-attempt/distinfo b/devel/hs-attempt/distinfo
new file mode 100644
index 000000000000..268a547462e6
--- /dev/null
+++ b/devel/hs-attempt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/attempt-0.3.1.1.tar.gz) = 65577df83673142aa9858a0b792721939e96dcf3dab0989081d6f8776045d679
+SIZE (cabal/attempt-0.3.1.1.tar.gz) = 3960
diff --git a/devel/hs-attempt/pkg-descr b/devel/hs-attempt/pkg-descr
new file mode 100644
index 000000000000..d4bb59a77144
--- /dev/null
+++ b/devel/hs-attempt/pkg-descr
@@ -0,0 +1,4 @@
+Defines a data type, Attempt, which has a Success and Failure
+constructor. Failure contains an extensible exception.
+
+WWW: http://github.com/snoyberg/attempt/tree/master
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index c525d0767d89..779d6cf0fabf 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -20,6 +20,7 @@ ansi-terminal_port= devel/hs-ansi-terminal
ansi-wl-pprint_port= devel/hs-ansi-wl-pprint
arrows_port= devel/hs-arrows
asn1-data_port= devel/hs-asn1-data
+attempt_port= devel/hs-attempt
attoparsec_port= textproc/hs-attoparsec
attoparsec-enumerator_port= textproc/hs-attoparsec-enumerator
base-unicode-symbols_port= devel/hs-base-unicode-symbols