aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-cookie/Makefile20
-rw-r--r--www/hs-cookie/distinfo2
-rw-r--r--www/hs-cookie/pkg-descr3
5 files changed, 27 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 36e4ffa323e7..67691cd38b74 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -59,6 +59,7 @@ contravariant_port= math/hs-contravariant
control-monad-attempt_port= devel/hs-control-monad-attempt
convertible_port= devel/hs-convertible
convertible-text_port= devel/hs-convertible-text
+cookie_port= www/hs-cookie
cpphs_port= devel/hs-cpphs # executable
cprng-aes_port= security/hs-cprng-aes
criterion_port= benchmarks/hs-criterion
diff --git a/www/Makefile b/www/Makefile
index 84068bf9fb52..584e02067740 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -281,6 +281,7 @@
SUBDIR += hs-HTTP
SUBDIR += hs-authenticate
SUBDIR += hs-cgi
+ SUBDIR += hs-cookie
SUBDIR += hs-css-text
SUBDIR += hs-fastcgi
SUBDIR += hs-gitit
diff --git a/www/hs-cookie/Makefile b/www/hs-cookie/Makefile
new file mode 100644
index 000000000000..385b94c04336
--- /dev/null
+++ b/www/hs-cookie/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-cookie
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cookie
+PORTVERSION= 0.3.0.2
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= HTTP cookie parsing and rendering
+
+LICENSE= BSD
+
+USE_CABAL= blaze-builder>=0.2.1 text>=0.7
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-cookie/distinfo b/www/hs-cookie/distinfo
new file mode 100644
index 000000000000..46bea0933bfe
--- /dev/null
+++ b/www/hs-cookie/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/cookie-0.3.0.2.tar.gz) = 3a66f05b70a1c546d0f64bc0ff70a11f4d71c2ba6ee5cdb040722bd655a67e88
+SIZE (cabal/cookie-0.3.0.2.tar.gz) = 2859
diff --git a/www/hs-cookie/pkg-descr b/www/hs-cookie/pkg-descr
new file mode 100644
index 000000000000..8756dbfd6cc4
--- /dev/null
+++ b/www/hs-cookie/pkg-descr
@@ -0,0 +1,3 @@
+HTTP cookie parsing and rendering.
+
+WWW: http://github.com/snoyberg/cookie