aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/sox/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index 0efc4a8d0e69..2d0ed9ff3517 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -39,6 +39,7 @@ OPTIONS= AO "Enable libao output" on \
LADSPA "Audio plugin support" off \
LAME "Enable mp3 encoding with LAME" ${_LAME} \
MAD "Enable mp3 decoding with MAD" on \
+ PNG "Enable PNG spectrogram creation" on \
SAMPLERATE "Enable libsamplerate" on \
SNDFILE "Enable libsndfile" on \
VORBIS "Enable Ogg Vorbis support" on \
@@ -50,7 +51,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
.if !defined(WITH_LAME) && !defined(WITH_MAD)
PLIST_SUB+= PLIST_MP3="@comment "
@@ -143,6 +143,13 @@ LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
CONFIGURE_ARGS+= --without-mad
.endif
+.if defined(WITH_PNG)
+CONFIGURE_ARGS+= --with-png
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+= --without-png
+.endif
+
.if defined(WITH_GSM)
CONFIGURE_ARGS+= --with-external-gsm
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm