aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-BibTeX/Makefile34
-rw-r--r--textproc/p5-Text-BibTeX/distinfo2
-rw-r--r--textproc/p5-Text-BibTeX/pkg-descr4
-rw-r--r--textproc/p5-Text-BibTeX/pkg-plist19
5 files changed, 60 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 90d52731e0ad..07f1143cd9ff 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -268,6 +268,7 @@
SUBDIR += p5-TeX-Hyphen
SUBDIR += p5-Text-Autoformat
SUBDIR += p5-Text-Balanced
+ SUBDIR += p5-Text-BibTeX
SUBDIR += p5-Text-Bind
SUBDIR += p5-Text-CSV
SUBDIR += p5-Text-CSV_XS
diff --git a/textproc/p5-Text-BibTeX/Makefile b/textproc/p5-Text-BibTeX/Makefile
new file mode 100644
index 000000000000..bfa4fc7d3fb7
--- /dev/null
+++ b/textproc/p5-Text-BibTeX/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Text-BibTeX
+# Date created: Mon Jan 19 2003
+# Whom: David Bremner <bremner@unb.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-BibTeX
+PORTVERSION= 0.34
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= biblio/bibtex/utils/btOOL
+PKGNAMEPREFIX= p5-
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz btparse-0.33.tar.gz
+
+MAINTAINER= bremner@unb.ca
+COMMENT= Text::BibTeX - Manipulate BibTeX files from perl
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Text::BibTeX.3 \
+ Text::BibTeX::Bib.3 \
+ Text::BibTeX::BibFormat.3 \
+ Text::BibTeX::BibSort.3 \
+ Text::BibTeX::Entry.3 \
+ Text::BibTeX::File.3 \
+ Text::BibTeX::Name.3 \
+ Text::BibTeX::NameFormat.3 \
+ Text::BibTeX::Structure.3 \
+ Text::BibTeX::Value.3 \
+ btool_faq.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-BibTeX/distinfo b/textproc/p5-Text-BibTeX/distinfo
new file mode 100644
index 000000000000..7a186cd97fef
--- /dev/null
+++ b/textproc/p5-Text-BibTeX/distinfo
@@ -0,0 +1,2 @@
+MD5 (Text-BibTeX-0.34.tar.gz) = 52058d8cc08307438857a375cbaa9264
+MD5 (btparse-0.33.tar.gz) = 426da135e8cb2ee36278b578b12453a4
diff --git a/textproc/p5-Text-BibTeX/pkg-descr b/textproc/p5-Text-BibTeX/pkg-descr
new file mode 100644
index 000000000000..b2f90e64b729
--- /dev/null
+++ b/textproc/p5-Text-BibTeX/pkg-descr
@@ -0,0 +1,4 @@
+Text::BibTeX provides objected oriented parsing and formatting of
+BibTeX files from within perl.
+
+WWW: http://www.gerg.ca/software/btOOL/
diff --git a/textproc/p5-Text-BibTeX/pkg-plist b/textproc/p5-Text-BibTeX/pkg-plist
new file mode 100644
index 000000000000..eeb6acf8b18c
--- /dev/null
+++ b/textproc/p5-Text-BibTeX/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/mach/Text/BibTeX.pm
+%%SITE_PERL%%/mach/Text/BibTeX/Bib.pm
+%%SITE_PERL%%/mach/Text/BibTeX/BibFormat.pm
+%%SITE_PERL%%/mach/Text/BibTeX/BibSort.pm
+%%SITE_PERL%%/mach/Text/BibTeX/Entry.pm
+%%SITE_PERL%%/mach/Text/BibTeX/File.pm
+%%SITE_PERL%%/mach/Text/BibTeX/Name.pm
+%%SITE_PERL%%/mach/Text/BibTeX/NameFormat.pm
+%%SITE_PERL%%/mach/Text/BibTeX/Structure.pm
+%%SITE_PERL%%/mach/Text/BibTeX/Value.pm
+%%SITE_PERL%%/mach/Text/btool_faq.pod
+%%SITE_PERL%%/mach/auto/Text/BibTeX/.packlist
+%%SITE_PERL%%/mach/auto/Text/BibTeX/BibTeX.bs
+%%SITE_PERL%%/mach/auto/Text/BibTeX/BibTeX.so
+@dirrm %%SITE_PERL%%/mach/Text/BibTeX
+@dirrm %%SITE_PERL%%/mach/auto/Text/BibTeX
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/mach/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Text 2>/dev/null || true