aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/domc/Makefile4
-rw-r--r--textproc/linux-aspell/Makefile2
-rw-r--r--textproc/linux-f10-aspell/Makefile2
-rw-r--r--textproc/linux-f8-aspell/Makefile2
-rw-r--r--textproc/ruby-xslt/Makefile7
-rw-r--r--textproc/xalan-c/Makefile4
-rw-r--r--www/webfs/Makefile8
-rw-r--r--x11-wm/pawm/Makefile12
-rw-r--r--x11/fbdesk/Makefile6
9 files changed, 6 insertions, 41 deletions
diff --git a/textproc/domc/Makefile b/textproc/domc/Makefile
index 1389614b3ca5..fdac26942df9 100644
--- a/textproc/domc/Makefile
+++ b/textproc/domc/Makefile
@@ -39,8 +39,4 @@ PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
IGNORE= requires wchar functions to use the produced library
.endif
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
.include <bsd.port.post.mk>
diff --git a/textproc/linux-aspell/Makefile b/textproc/linux-aspell/Makefile
index 8be47ef606df..71412f564781 100644
--- a/textproc/linux-aspell/Makefile
+++ b/textproc/linux-aspell/Makefile
@@ -79,7 +79,7 @@ DICT_SUFFIX= .tar.bz2
.include <bsd.port.pre.mk>
-.if (${OSVERSION} < 500021) && (${OSVERSION} >= 500000 || ${OSVERSION} < 440000)
+.if ${OSVERSION} < 500021
BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
.endif
diff --git a/textproc/linux-f10-aspell/Makefile b/textproc/linux-f10-aspell/Makefile
index 8be47ef606df..71412f564781 100644
--- a/textproc/linux-f10-aspell/Makefile
+++ b/textproc/linux-f10-aspell/Makefile
@@ -79,7 +79,7 @@ DICT_SUFFIX= .tar.bz2
.include <bsd.port.pre.mk>
-.if (${OSVERSION} < 500021) && (${OSVERSION} >= 500000 || ${OSVERSION} < 440000)
+.if ${OSVERSION} < 500021
BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
.endif
diff --git a/textproc/linux-f8-aspell/Makefile b/textproc/linux-f8-aspell/Makefile
index 8be47ef606df..71412f564781 100644
--- a/textproc/linux-f8-aspell/Makefile
+++ b/textproc/linux-f8-aspell/Makefile
@@ -79,7 +79,7 @@ DICT_SUFFIX= .tar.bz2
.include <bsd.port.pre.mk>
-.if (${OSVERSION} < 500021) && (${OSVERSION} >= 500000 || ${OSVERSION} < 440000)
+.if ${OSVERSION} < 500021
BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
.endif
diff --git a/textproc/ruby-xslt/Makefile b/textproc/ruby-xslt/Makefile
index 0d60031dd565..6ed2d76ea25a 100644
--- a/textproc/ruby-xslt/Makefile
+++ b/textproc/ruby-xslt/Makefile
@@ -22,15 +22,10 @@ USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
-.include <bsd.port.pre.mk>
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
.endif
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index fc08be4f8449..9d310165fb4d 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -55,10 +55,6 @@ USE_GMAKE= yes
MAKE_ENV+= XALANCROOT=${WRKSRC}
MAKE_ENV+= XERCESCROOT=${XERCESCROOT}
-.if ( ${OSVERSION} < 500000 )
-EXTRA_CFLAGS= -ftemplate-depth-20
-.endif
-
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= runConfigure
CONFIGURE_ENV+= XALANCROOT=${WRKSRC}
diff --git a/www/webfs/Makefile b/www/webfs/Makefile
index ee3cd90fec7c..32e3620d0e77 100644
--- a/www/webfs/Makefile
+++ b/www/webfs/Makefile
@@ -27,12 +27,6 @@ MAKE_ENV+= LDLIBS="-lssl -lcrypto" USE_DIET=no
MAN1= webfsd.1
MIMEFILE?= ${LOCALBASE}/etc/mime.types
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 400000
-BROKEN= "Requires FreeBSD 4.x or greater due to ipv6 support"
-.endif
-
pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "==========================================="
@@ -53,4 +47,4 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/webfsd ${PREFIX}/sbin
@${INSTALL_MAN} ${WRKSRC}/webfsd.man ${PREFIX}/man/man1/webfsd.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
index f2679d14232d..d26b2861f33b 100644
--- a/x11-wm/pawm/Makefile
+++ b/x11-wm/pawm/Makefile
@@ -25,12 +25,6 @@ LDFLAGS= -lm -L${X11BASE}/lib -lXpm
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-CFLAGS+= -Dintmax_t=u_int32_t -Duintmax_t=u_int32_t \
- -Dstrtoimax=strtoll -Dstrtoumax=strtoull \
- -DSIZE_MAX=UINT_MAX
-.endif
-
LDFLAGS+= -lXrandr
.if defined(WITHOUT_XFT)
CFLAGS+= -DDISABLE_XFT
@@ -47,12 +41,6 @@ CFLAGS+= -DENABLE_STARTUP -DSN_API_NOT_YET_FROZEN \
LDFLAGS+= `pkg-config --libs libstartup-notification-1.0`
.endif
-post-patch:
-.if ${OSVERSION} < 500000
- @${GREP} -lR "<stdint\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
- 's|<stdint\.h>|<inttypes.h>|g'
-.endif
-
do-configure:
@${ECHO_CMD} -n > ${WRKSRC}/config.h
@${ECHO_CMD} '#define PROJECT "${PORTNAME}"' >> ${WRKSRC}/config.h
diff --git a/x11/fbdesk/Makefile b/x11/fbdesk/Makefile
index c07bac39910a..7e6ac5faa0f2 100644
--- a/x11/fbdesk/Makefile
+++ b/x11/fbdesk/Makefile
@@ -28,13 +28,9 @@ GNU_CONFIGURE= yes
PORTDOCS= COPYING ChangeLog INSTALL README
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
post-patch:
${REINPLACE_CMD} -e "s/inttypes\.h/stdint\.h/" \
${WRKSRC}/src/FbTk/Timer.hh
-.endif
post-install:
.ifndef (NOPORTDOCS)
@@ -44,4 +40,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>