aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/p5-Crypt-RandPasswd/Makefile1
-rw-r--r--security/p5-Crypt-RandPasswd/files/patch-lib-Crypt-RandPasswd.pm10
2 files changed, 11 insertions, 0 deletions
diff --git a/security/p5-Crypt-RandPasswd/Makefile b/security/p5-Crypt-RandPasswd/Makefile
index 0ae1826e900f..f2d92e5efefb 100644
--- a/security/p5-Crypt-RandPasswd/Makefile
+++ b/security/p5-Crypt-RandPasswd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Crypt-RandPasswd
PORTVERSION= 0.02
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/security/p5-Crypt-RandPasswd/files/patch-lib-Crypt-RandPasswd.pm b/security/p5-Crypt-RandPasswd/files/patch-lib-Crypt-RandPasswd.pm
new file mode 100644
index 000000000000..12aa892b3c79
--- /dev/null
+++ b/security/p5-Crypt-RandPasswd/files/patch-lib-Crypt-RandPasswd.pm
@@ -0,0 +1,10 @@
+--- lib/Crypt/RandPasswd.pm.orig 2011-08-19 17:39:52.000000000 -0400
++++ lib/Crypt/RandPasswd.pm 2011-08-19 17:40:47.000000000 -0400
+@@ -1466,6 +1466,7 @@
+ =cut
+
+ sub random_chars_in_range($$$$) {
++ @_ > 4 and shift;
+ my( $minlen, $maxlen, $lo_char, $hi_char ) = @_;
+
+ $minlen <= $maxlen or die "minlen $minlen is greater than maxlen $maxlen";