aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/py-spf/Makefile19
-rw-r--r--mail/py-spf/distinfo6
-rw-r--r--mail/py-spf/pkg-descr22
-rw-r--r--mail/py-spf/pkg-plist9
4 files changed, 33 insertions, 23 deletions
diff --git a/mail/py-spf/Makefile b/mail/py-spf/Makefile
index 4e04493df9dd..4998abbde544 100644
--- a/mail/py-spf/Makefile
+++ b/mail/py-spf/Makefile
@@ -6,37 +6,30 @@
#
PORTNAME= spf
-PORTVERSION= 1.6
+PORTVERSION= 2.0.4
CATEGORIES= mail python
-MASTER_SITES= http://www.wayforward.net/spf/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pymilter
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= mnag@FreeBSD.org
-COMMENT= Python implementation of SPF
+COMMENT= Python implementation of the RFC 4408 SPF protocol
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/DNS/__init__.py:${PORTSDIR}/dns/py-dns
DIST_SUBDIR= python
USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= pyspf
DOCSDIR?= ${PREFIX}/share/doc/py-${PORTNAME}
-PLIST_FILES= bin/spf.py \
- %%PYTHON_SITELIBDIR%%/spf.py \
- %%PYTHON_SITELIBDIR%%/spf.pyc \
- %%PYTHON_SITELIBDIR%%/spf.pyo
-
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}
.endif
@${CHMOD} 755 ${PYTHONPREFIX_SITELIBDIR}/spf.py
@${LN} -s ${PYTHONPREFIX_SITELIBDIR}/spf.py ${PREFIX}/bin
diff --git a/mail/py-spf/distinfo b/mail/py-spf/distinfo
index 6e00f92637e8..177300925207 100644
--- a/mail/py-spf/distinfo
+++ b/mail/py-spf/distinfo
@@ -1,3 +1,3 @@
-MD5 (python/pyspf-1.6.tar.gz) = 7ff35d8f9db41f2f7e0068f78f243a3d
-SHA256 (python/pyspf-1.6.tar.gz) = 0aff908adc2187b19d33b47deef448093b053419823ec1da487032f5351850cb
-SIZE (python/pyspf-1.6.tar.gz) = 11424
+MD5 (python/pyspf-2.0.4.tar.gz) = 6a40662e4e4b36be0633983a586c390e
+SHA256 (python/pyspf-2.0.4.tar.gz) = fedd19918a1b3496ca1f2f3692758f8cb7657774c759add349b4cb61f8d20ec8
+SIZE (python/pyspf-2.0.4.tar.gz) = 36163
diff --git a/mail/py-spf/pkg-descr b/mail/py-spf/pkg-descr
index 64089242b2a3..85bcb8616e50 100644
--- a/mail/py-spf/pkg-descr
+++ b/mail/py-spf/pkg-descr
@@ -1,11 +1,19 @@
-Python implementation of SPF (Sender Permitted From)
+The pyspf Python module has been released as version 2.0. pyspf 2.0
+was the first SPF implementation to fully conform to RFC 4408. This
+release has also added IPv6 support. pyspf is the library behind
+several of the open SPF project's SPF record testing tools.
-For more information about SPF, a tool against email forgery, see
- http://spf.pobox.com
+License: Python Software Foundation License
-For news, bugfixes, etc. visit the home page for this implementation at
- http://www.wayforward.net/spf/
+Author:
+Terence Way terry@wayforward.net
+http://www.wayforward.net/spf/
-WWW: http://www.wayforward.net/spf/
+Maintainers:
+Stuart Gathman stuart@bmsi.com
+Scott Kitterman scott@kitterman.com
+http://pypi.python.org/pypi/pyspf
-Marcus Alves Grando <mnag@FreeBSD.org>
+Currently part of the pymilter project: http://pymilter.sourceforge.net
+
+WWW: http://pypi.python.org/pypi/pyspf
diff --git a/mail/py-spf/pkg-plist b/mail/py-spf/pkg-plist
new file mode 100644
index 000000000000..f14e3f95886b
--- /dev/null
+++ b/mail/py-spf/pkg-plist
@@ -0,0 +1,9 @@
+bin/spf.py
+bin/spfquery.py
+bin/type99.py
+%%PYTHON_SITELIBDIR%%/spf.py
+%%PYTHON_SITELIBDIR%%/spf.pyc
+%%PYTHON_SITELIBDIR%%/spf.pyo
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%