aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-base-unicode-symbols/Makefile20
-rw-r--r--devel/hs-base-unicode-symbols/distinfo2
-rw-r--r--devel/hs-base-unicode-symbols/pkg-descr10
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cb65d269fa04..39efc0823abd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -585,6 +585,7 @@
SUBDIR += hs-ansi-terminal
SUBDIR += hs-ansi-wl-pprint
SUBDIR += hs-arrows
+ SUBDIR += hs-base-unicode-symbols
SUBDIR += hs-base16-bytestring
SUBDIR += hs-base64-bytestring
SUBDIR += hs-binary
diff --git a/devel/hs-base-unicode-symbols/Makefile b/devel/hs-base-unicode-symbols/Makefile
new file mode 100644
index 000000000000..dee02e2fd174
--- /dev/null
+++ b/devel/hs-base-unicode-symbols/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-base-unicode-symbols
+# Date created: September 24, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= base-unicode-symbols
+PORTVERSION= 0.2.2.3
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Unicode alternatives for common functions and operators
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-base-unicode-symbols/distinfo b/devel/hs-base-unicode-symbols/distinfo
new file mode 100644
index 000000000000..e98d4e42b8a5
--- /dev/null
+++ b/devel/hs-base-unicode-symbols/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/base-unicode-symbols-0.2.2.3.tar.gz) = 1201fcc936cf4328153d9ac7e20f797d904ac14ed6493689ddb1cfe61bb30320
+SIZE (cabal/base-unicode-symbols-0.2.2.3.tar.gz) = 5549
diff --git a/devel/hs-base-unicode-symbols/pkg-descr b/devel/hs-base-unicode-symbols/pkg-descr
new file mode 100644
index 000000000000..4a623dbba5f6
--- /dev/null
+++ b/devel/hs-base-unicode-symbols/pkg-descr
@@ -0,0 +1,10 @@
+This package defines new symbols for a number of functions, operators
+and types in the base package. All symbols are documented with their
+actual definition and information regarding their Unicode code point.
+They should be completely interchangeable with their definitions.
+
+For further Unicode goodness you can enable the UnicodeSyntax language
+extension. This extension enables Unicode characters to be used to
+stand for certain ASCII character sequences.
+
+WWW: http://haskell.org/haskellwiki/Unicode-symbols
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index a0234d857b52..8a30fbf5e486 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -21,6 +21,7 @@ ansi-wl-pprint_port= devel/hs-ansi-wl-pprint
arrows_port= devel/hs-arrows
attoparsec_port= textproc/hs-attoparsec
attoparsec-enumerator_port= textproc/hs-attoparsec-enumerator
+base-unicode-symbols_port= devel/hs-base-unicode-symbols
base16-bytestring_port= devel/hs-base16-bytestring
base64-bytestring_port= devel/hs-base64-bytestring
binary_port= devel/hs-binary