aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/kpcli/Makefile6
-rw-r--r--security/kpcli/distinfo4
2 files changed, 5 insertions, 5 deletions
diff --git a/security/kpcli/Makefile b/security/kpcli/Makefile
index d65ab8c20857..d69cc93f810a 100644
--- a/security/kpcli/Makefile
+++ b/security/kpcli/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= kpcli
-PORTVERSION= 2.3
+PORTVERSION= 2.5
PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/kpcli/
@@ -20,10 +20,10 @@ RUN_DEPENDS= p5-Crypt-Rijndael>=1.08:${PORTSDIR}/security/p5-Crypt-Rijndael \
p5-Term-ShellUI>=0.9:${PORTSDIR}/shells/p5-Term-ShellUI \
p5-ReadLine-Gnu>=1.19:${PORTSDIR}/devel/p5-ReadLine-Gnu \
p5-Data-Password>=0:${PORTSDIR}/security/p5-Data-Password
-
BUILD_DEPENDS:= ${RUN_DEPENDS}
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= kpcli
PLIST_FILES= bin/kpcli man/man1/${PORTNAME}.1.gz
do-extract:
diff --git a/security/kpcli/distinfo b/security/kpcli/distinfo
index 2598df5fbed4..62301de6be22 100644
--- a/security/kpcli/distinfo
+++ b/security/kpcli/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kpcli-2.3.pl) = a536f01c7db2460d4b31e83fa59dd1200e5194f9a8a626eb8cf429e5a6d4329c
-SIZE (kpcli-2.3.pl) = 105864
+SHA256 (kpcli-2.5.pl) = d69b2e875c98558ebd86203ff24844f8ed40dffcdc06b21fbaa8ed02d90d4217
+SIZE (kpcli-2.5.pl) = 128268
\ | | |/ | |/| | * | Merge pull request #946 from 0xProject/fix/contracts/signatureValidatorCommentsAmir Bandeali2018-08-091-4/+9 | |\ \ | | |/ | |/| | | * fix comments and styling for MixinSignatureValidatorAmir Bandeali2018-08-091-4/+9 * | | Change amir picturefragosti2018-08-093-1/+1 |/ / * | Merge pull request #947 from 0xProject/feature/confirm-before-publishAlex Browne2018-08-092-9/+15 |\ \ | * | fix(monorepo-scripts): Fix typo in git tag commandAlex Browne2018-08-091-1/+1 | * | feat(monorepo-scripts): Add confirmation prompt before publishingAlex Browne2018-08-091-8/+14 * | | Merge pull request #945 from 0xProject/fix/typescript-2.9.2Alex Browne2018-08-0931-34/+49 |\ \ \ | |_|/ |/| | | * | Update TypeScript to version 2.9.2Alex Browne2018-08-0931-34/+49 | |/ * | Use asm for hashEIP712Message, increment free memory pointer after asm hashin...Amir Bandeali2018-08-092-9/+28 * | Fix comments, styling, and optimize hashOrderAmir Bandeali2018-08-083-25/+33 |/ * Remove assertion commentsBrandon Millman2018-08-071-4/+0 * Remove 0x test case from hexSchema testBrandon Millman2018-08-061-1/+1 * Update CHANGELOGsBrandon Millman2018-08-062-0/+13 * Add some test cases that stress slippageBufferAmount paramBrandon Millman2018-08-061-6/+15 * Add tests for findFeeOrdersThatCoverFeesForTargetOrdersBrandon Millman2018-08-064-20/+165 * Change orderStates param name to remaingFillableMakerAssetAmountsBrandon Millman2018-08-063-91/+69 * Implement first round of tests for findOrdersThatCoverMakerAssetFillAmountBrandon Millman2018-08-065-12/+222 * Update hex schema to match 0xBrandon Millman2018-08-061-1/+1 * Move helper functions into order-utilsBrandon Millman2018-08-063-100/+111 * Add findFeeOrdersThatCoverFeesForTargetOrders to ForwarderWrapperBrandon Millman2018-08-061-5/+60 * Add findOrdersThatCoverMakerAssetFillAmount static method on ForwarderWrapperBrandon Millman2018-08-061-1/+44 * Move CreateOrderOpts into shared typesBrandon Millman2018-08-063-12/+22 * Update createFactory to accept one createOrderOpts param to encompass all opt...Brandon Millman2018-08-064-41/+59 * PrettierBrandon Millman2018-08-041-1/+0 * Fix CHANGELOGsBrandon Millman2018-08-043-3/+12 * Update orderFactory interfaceBrandon Millman2018-08-044-33/+28 * Rename to calldata utilsBrandon Millman2018-08-033-16/+16 * Add missing PR numbersBrandon Millman2018-08-032-2/+3 * CHANGELOGBrandon Millman2018-08-021-0/+4 * Add testsBrandon Millman2018-08-022-18/+85 * Add createOrder with no signing to orderFactoryBrandon Millman2018-08-023-6/+45 * Create marketBuyOrdersOptimizationsBrandon Millman2018-08-023-8/+63 * Update contract-wrappers CHANGELOG.jsonBrandon Millman2018-08-021-0/+9 * Merge pull request #934 from 0xProject/feature/contract-wrappers/forwaderBrandon Millman2018-08-0211-10/+448 |\ | * Clarify ethAmount is in weiBrandon Millman2018-07-311-2/+2 | * Update forwarder_wrapper_testBrandon Millman2018-07-311-0/+16 | * Add more assertionsBrandon Millman2018-07-313-6/+102 | * Write initial test for forwarder_wrapperBrandon Millman2018-07-312-16/+73 | * Fix spelling error in exchange wrapper testsBrandon Millman2018-07-311-1/+1 | * Add getOrdersInfo to exchange_wrapperBrandon Millman2018-07-313-3/+32 | * Implement initial forwarder wrapperBrandon Millman2018-07-318-2/+242 * | Add the CHANGELOG entry for #909Leonid Logvinov2018-07-311-0/+9 * | Merge branch 'development' into ritave/resolver-check-dirsLeonid Logvinov2018-07-31201-6198/+59132 |\| | * Add back tags in htmlBrandon Millman2018-07-311-1/+7 | * Fix jobs page overflow issueBrandon Millman2018-07-303-4/+6 | * Create MetaTags componentBrandon Millman2018-07-306-75/+117 | * Merge branch 'development' of https://github.com/0xProject/0x-monorepo into f...fragosti2018-07-28188-5949/+58670 | |\ | | * Add combinatorial tests for internal Exchange functions (#807)Alex Browne2018-07-2723-1269/+780 | | * PublishFabio Berger2018-07-2627-151/+151 | | * Updated CHANGELOGSFabio Berger2018-07-2636-10/+184 | | * Point to actual current versionFabio Berger2018-07-2611-22/+22 | | * Add changelog entries for other RCs that did publishFabio Berger2018-07-262-0/+16 | | * Fix changelogs and package versions for ones that weren't publishedFabio Berger2018-07-2616-21/+13 | | * PublishFabio Berger2018-07-2631-252/+252 | | * Updated CHANGELOGSFabio Berger2018-07-2652-7/+289 | | * Still test unrunnable packages for compilation issuesFabio Berger2018-07-261-8/+8 | | * Add changelog entries for next RC publishFabio Berger2018-07-267-0/+56 | | * Split running packages that cannot be run in a node.js scriptFabio Berger2018-07-261-1/+9 | | * Fix accidental import from test folderFabio Berger2018-07-261-1/+1 | | * Re-enable deleted the dir after test runsFabio Berger2018-07-261-1/+1 | | * Change test:installation so it also causes run-time errors to appearFabio Berger2018-07-261-3/+10 | | * Fix lint issueFabio Berger2018-07-261-2/+1 | | * Always append monorepo root path so script can be called from anywhereFabio Berger2018-07-261-3/+5 | | * Delete any remenants of test-env dir before creating a new oneFabio Berger2018-07-261-0/+1 | | * Print version that will be testedFabio Berger2018-07-261-1/+1 | | * Add ending slashFabio Berger2018-07-261-1/+1 | | * Add support for testing installations post-publish as wellFabio Berger2018-07-261-2/+4 | | * Fix asset pathFabio Berger2018-07-261-2/+2 | | * PublishFabio Berger2018-07-2631-261/+257 | | * Updated CHANGELOGSFabio Berger2018-07-2652-8/+299 | | * Fix linterFabio Berger2018-07-262-3/+0 | | * Revert to using execAsyncFabio Berger2018-07-261-10/+2 | | * Revert to publishing ethereum-typesFabio Berger2018-07-2618-18/+17 | | * Fix marshaller importFabio Berger2018-07-261-1/+1 | | * Temporarily have all packages depend on an older, published version of ethere...Fabio Berger2018-07-2617-17/+17 | | * Temporarily make ethereum-types private to exclude from publishingFabio Berger2018-07-261-0/+1 | | * Fix changelogsFabio Berger2018-07-266-3/+30 | | * Remove artifacts for gitFabio Berger2018-07-264-3256/+0 | | * Call 'lerna publish' with spawn so we see stderr and stdout in real-timeFabio Berger2018-07-261-2/+10 | | * Merge pull request #902 from 0xProject/feature/web3-wrapper/unexport-marshallerFrancesco Agosti2018-07-263-2/+6 | | |\ | | | * Merge branch 'v2-prototype' of https://github.com/0xProject/0x-monorepo into ...fragosti2018-07-26172-3250/+3947 | | | |\ | | | * | Add remove marshaller to changelog notesfragosti2018-07-201-0/+8 | | | * | Stop exporting marshaller from web3-wrapperfragosti2018-07-203-6/+2 | | * | | Remove careers page feature flagBrandon Millman2018-07-262-14/+2 | | * | | Merge pull request #893 from 0xProject/feature/website/jobs-page-part2Brandon Millman2018-07-2630-438/+420 | | |\ \ \ | | | * | | Header copy changeBrandon Millman2018-07-261-8/+7 | | | * | | Margin polishBrandon Millman2018-07-262-4/+4 | | | * | | Update open positions sectionBrandon Millman2018-07-253-10/+29 | | | * | | Update benefits sectionBrandon Millman2018-07-253-23/+48 | | | * | | Update mission sectionBrandon Millman2018-07-252-18/+47 | | | * | | Header copy updatesBrandon Millman2018-07-251-6/+16 | | | * | | Use isMobileWidth utilBrandon Millman2018-07-251-1/+1 | | | * | | Use our image component in missionBrandon Millman2018-07-252-2/+7 | | | * | | Always go to open positions when clicking CTABrandon Millman2018-07-241-0/+1 | | | * | | Fix hiding of dots on small screensBrandon Millman2018-07-241-2/+2 | | | * | | Merge branch 'v2-prototype' into feature/website/jobs-page-part2Brandon Millman2018-07-24115-2279/+2704 | | | |\ \ \ | | | * \ \ \ Merge branch 'v2-prototype' into feature/website/jobs-page-part2Brandon Millman2018-07-21112-679/+1030 | | | |\ \ \ \ | | | * | | | | Update hr colorBrandon Millman2018-07-192-4/+1 | | | * | | | | Fix lint errorsBrandon Millman2018-07-193-26/+0 | | | * | | | | Add /careers route and fix hr stylingBrandon Millman2018-07-197-9/+19 | | | * | | | | Fix typosBrandon Millman2018-07-192-5/+5 | | | * | | | | Fix key errors and typoBrandon Millman2018-07-192-5/+4 | | | * | | | | Fix padding on open positions sectionBrandon Millman2018-07-191-1/+1 | | | * | | | | Add dots on heroBrandon Millman2018-07-191-1/+11 | | | * | | | | Padding fixesBrandon Millman2018-07-192-7/+4 | | | * | | | | Update open positions sectionBrandon Millman2018-07-193-85/+78 | | | * | | | | Benefits and values sectionsBrandon Millman2018-07-1922-284/+209 | | | * | | | | Remove sectionsBrandon Millman2018-07-19