aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile8
-rw-r--r--net-p2p/rblibtorrent-devel/Makefile8
-rw-r--r--net-p2p/rblibtorrent/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index 8ffb7968ba19..df698da0cbf1 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -38,10 +38,16 @@ USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not compile on 6.x
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e 's|^AM_CFLAGS|AM_CPPFLAGS|g ; \
s|@BOOST_SYSTEM_LIB@||g' ${WRKSRC}/src/Makefile.am
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-p2p/rblibtorrent-devel/Makefile b/net-p2p/rblibtorrent-devel/Makefile
index 8ffb7968ba19..df698da0cbf1 100644
--- a/net-p2p/rblibtorrent-devel/Makefile
+++ b/net-p2p/rblibtorrent-devel/Makefile
@@ -38,10 +38,16 @@ USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not compile on 6.x
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e 's|^AM_CFLAGS|AM_CPPFLAGS|g ; \
s|@BOOST_SYSTEM_LIB@||g' ${WRKSRC}/src/Makefile.am
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-p2p/rblibtorrent/Makefile b/net-p2p/rblibtorrent/Makefile
index cf988ff4eb93..222f498f30a6 100644
--- a/net-p2p/rblibtorrent/Makefile
+++ b/net-p2p/rblibtorrent/Makefile
@@ -26,8 +26,14 @@ CONFLICTS= libtorrent-[0-9]* \
libtorrent-devel-[0-9]* \
rblibtorrent-devel-[0-9]*
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not compile on 6.x
+.endif
+
post-install:
@cd ${PREFIX}/lib && ${LN} -sf libtorrent-0.13.so libtorrent.so.1 && \
${LN} -sf libtorrent.so.1 libtorrent.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>