aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/pkg-plist1
5 files changed, 16 insertions, 15 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index d72d6829e620..d05bc8042c6a 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -31,8 +31,8 @@ LICENSE= MPL
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.0a.2017.07.29
-HASH= 93ae9a0
+ISCVERSION= 9.12.0a.2017.08.05
+HASH= 13053ff
USES= cpe libedit
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 7bc41c844015..285b72bcaad3 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501497412
-SHA256 (bind9-93ae9a0.tar.gz) = 3796835eae382f9e299008d5cf1f2e2285e58029590c951d9c9cde5ca4a61fc0
-SIZE (bind9-93ae9a0.tar.gz) = 11886050
+TIMESTAMP = 1502100339
+SHA256 (bind9-13053ff.tar.gz) = 85947064a2626c80c819d326c3b53ae59d3e6887ca5708bf4ee5a8a4726fab30
+SIZE (bind9-13053ff.tar.gz) = 11906171
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 24e10eb7eab9..6277a14658a6 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2017-07-29 01:10:15 UTC
+--- bin/named/config.c.orig 2017-08-05 02:36:31 UTC
+++ bin/named/config.c
@@ -156,6 +156,8 @@ options {\n\
lame-ttl 600;\n\
@@ -9,7 +9,7 @@
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 90%;\n\
---- bin/named/server.c.orig 2017-07-29 01:10:15 UTC
+--- bin/named/server.c.orig 2017-08-05 02:36:31 UTC
+++ bin/named/server.c
@@ -3722,6 +3722,16 @@ configure_view(dns_view_t *view, dns_vie
}
@@ -28,7 +28,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2017-07-29 01:10:15 UTC
+--- lib/dns/include/dns/view.h.orig 2017-08-05 02:36:31 UTC
+++ lib/dns/include/dns/view.h
@@ -144,6 +144,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -39,9 +39,9 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2017-07-29 01:10:15 UTC
+--- lib/dns/resolver.c.orig 2017-08-05 02:36:31 UTC
+++ lib/dns/resolver.c
-@@ -5468,6 +5468,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5683,6 +5683,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -60,7 +60,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2017-07-29 01:10:15 UTC
+--- lib/isccfg/namedconf.c.orig 2017-08-05 02:36:31 UTC
+++ lib/isccfg/namedconf.c
@@ -1894,6 +1894,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 8bb046906c04..bbb1a18ffe6a 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-05-12 01:09:53 UTC
+--- configure.orig 2017-08-05 02:36:31 UTC
+++ configure
-@@ -14402,27 +14402,9 @@ done
+@@ -14408,27 +14408,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14465,47 +14447,7 @@ $as_echo "no" >&6; } ;;
+@@ -14471,47 +14453,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22825,7 +22767,7 @@ $as_echo "" >&6; }
+@@ -22997,7 +22939,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index b3a9e36a386c..c8af2f16274f 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -262,6 +262,7 @@ include/pk11/pk11.h
include/pk11/result.h
include/pk11/site.h
include/pkcs11/cryptoki.h
+include/pkcs11/eddsa.h
include/pkcs11/pkcs11.h
include/pkcs11/pkcs11f.h
include/pkcs11/pkcs11t.h