aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/pine4/Makefile7
-rw-r--r--mail/pine4/files/patch-ac20
-rw-r--r--mail/pine4/files/patch-pine_pine.hlp10
3 files changed, 35 insertions, 2 deletions
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index 1fb051360136..0dde99075791 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -23,6 +23,7 @@ COMMENT= PINE(tm) -- a Program for Internet News & Email
OPTIONS= PICO "Build and install pico, the default editor" on \
MAILDIR "Add a patch that provides maildir support" off \
+ PASSFILE "Support for a stored Password File (DANGEROUS)" off \
LDAP "Add support for LDAP" off \
IPV6 "Add support for IPv6" off
@@ -59,6 +60,11 @@ EXTRA_OPTS+= SSLTYPE=unix.nopwd
EXTRA_OPTS+= IP=6
.endif
+.if defined(WITH_PASSFILE)
+PASSFILE?= .pine.pwd
+EXTRA_OPTS+= EXTRACFLAGS="-DWITH_PASSFILE"
+.endif
+
MAN1= pine.1 pilot.1 rpdump.1 rpload.1
pre-fetch:
@@ -96,6 +102,7 @@ post-patch:
${SED} -e "s:/usr/local/etc/:${PREFIX}/etc/:g" \
-e "s:/usr/local/lib/:${PREFIX}/etc/:g" \
-e "s:@@PREFIX@@:${PREFIX}:g" \
+ -e "s:@@PASSFILE@@:${PASSFILE}:g" \
-e "s:/usr/local/pine.conf:${PREFIX}/etc/pine.conf:g" \
$$i.presed > $$i ; \
done
diff --git a/mail/pine4/files/patch-ac b/mail/pine4/files/patch-ac
index d5e533d5fcb0..08aa8b1ffc6c 100644
--- a/mail/pine4/files/patch-ac
+++ b/mail/pine4/files/patch-ac
@@ -1,5 +1,5 @@
*** pine/osdep/os-bsf.h.orig Fri May 23 09:05:21 2003
---- pine/osdep/os-bsf.h Fri Sep 5 01:44:20 2003
+--- pine/osdep/os-bsf.h Thu Aug 9 00:30:23 2007
***************
*** 87,93 ****
NOTE: You'll also have to make sure the appropriate osdep/postreap.*
@@ -29,6 +29,22 @@
The default printer when pine starts up for the first time with no printer
----*/
***************
+*** 250,255 ****
+--- 252,264 ----
+ #define MAX_SCREEN_COLS (170)
+ #define MAX_SCREEN_ROWS (200)
+
++ /*----------------------------------------------------------------------
++ File name used to store the user's server/id/password triple between
++ session. It is rooted in the same directory as the PINERC.
++ ----*/
++ #ifdef WITH_PASSFILE
++ #define PASSFILE "@@PASSFILE@@"
++ #endif
+
+ /*----------------------------------------------------------------------
+ Where to put the output of pine in debug mode. Files are created
+***************
*** 280,286 ****
8
9 logs gross details of command execution
@@ -37,7 +53,7 @@
---- 282,288 ----
+--- 289,295 ----
8
9 logs gross details of command execution
----*/
diff --git a/mail/pine4/files/patch-pine_pine.hlp b/mail/pine4/files/patch-pine_pine.hlp
new file mode 100644
index 000000000000..4c255da5fa53
--- /dev/null
+++ b/mail/pine4/files/patch-pine_pine.hlp
@@ -0,0 +1,10 @@
+--- pine/pine.hlp.orig 2007-08-09 00:17:46.000000000 -0700
++++ pine/pine.hlp 2007-08-09 00:23:00.000000000 -0700
+@@ -996,6 +996,7 @@
+ executable <Unix search path>/pine
+ persnl cfg ~/.pinerc
+ except cfg ~/.pinercex
++ password ~/@@PASSFILE@@
+ global cfg <!--#echo var="PINE_CONF_PATH"-->
+ fixed cfg <!--#echo var="PINE_CONF_FIXED_PATH"-->
+ local help <!--#echo var="PINE_INFO_PATH"-->