aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-void/Makefile20
-rw-r--r--devel/hs-void/distinfo2
-rw-r--r--devel/hs-void/pkg-descr4
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1643afa0624d..5a2f066f9efb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -657,6 +657,7 @@
SUBDIR += hs-uulib
SUBDIR += hs-vector
SUBDIR += hs-vector-algorithms
+ SUBDIR += hs-void
SUBDIR += htable
SUBDIR += hyena
SUBDIR += hypersrc
diff --git a/devel/hs-void/Makefile b/devel/hs-void/Makefile
new file mode 100644
index 000000000000..5bc6a90c1795
--- /dev/null
+++ b/devel/hs-void/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-void
+# Date created: July 16, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= void
+PORTVERSION= 0.5.4.3
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A Haskell 98 logically uninhabited data type
+
+LICENSE= BSD
+
+USE_CABAL= semigroups>=0.7.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-void/distinfo b/devel/hs-void/distinfo
new file mode 100644
index 000000000000..bb4f00f3a08c
--- /dev/null
+++ b/devel/hs-void/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/void-0.5.4.3.tar.gz) = b0d37aee2900fc9e17c50f3925f1248e66a4db8682a890874ed66d14569ff314
+SIZE (cabal/void-0.5.4.3.tar.gz) = 2055
diff --git a/devel/hs-void/pkg-descr b/devel/hs-void/pkg-descr
new file mode 100644
index 000000000000..ce75993aa13b
--- /dev/null
+++ b/devel/hs-void/pkg-descr
@@ -0,0 +1,4 @@
+A Haskell 98 logically uninhabited data type. Used to indicate that a
+given term should not exist.
+
+WWW: http://github.com/ekmett/void
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 2740701a7648..b500b1e457dc 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -187,6 +187,7 @@ uulib_port= devel/hs-uulib
vector_port= devel/hs-vector
vector-algorithms_port= devel/hs-vector-algorithms
vector-space_port= math/hs-vector-space
+void_port= devel/hs-void
vte_port= x11-toolkits/hs-vte
wai_port= www/hs-wai
warp_port= www/hs-warp