aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/workrave/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 1ceea6168a3e..376e3c949ef4 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -23,17 +23,15 @@ LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
LIB_DEPENDS+= gnet-2.0.0:${PORTSDIR}/net/gnet2
.endif
-USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 intltool
.if !defined(WITHOUT_GNOME)
USE_GNOME+= gnomepanel
.endif
-USE_GCC= 3.4
+USE_GCC= 3.4+
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-gconf
.if defined(WITHOUT_GNOME)
CONFIGURE_ARGS+=--disable-gnome