aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mozilla-devel/Makefile3
-rw-r--r--www/mozilla/Makefile3
-rw-r--r--www/seamonkey/Makefile3
-rw-r--r--www/seamonkey2/Makefile3
4 files changed, 8 insertions, 4 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 15a184b440ad..5947dc3804af 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -219,7 +219,8 @@ post-patch:
@${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
@${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' \
+ s|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|/usr/X11R6|${X11BASE}|g' \
${WRKSRC}/configure \
${WRKSRC}/nsprpub/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 67deaff032a5..2dd54d7ebc81 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -222,7 +222,8 @@ post-patch:
@${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
@${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' \
+ s|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|/usr/X11R6|${X11BASE}|g' \
${WRKSRC}/configure \
${WRKSRC}/nsprpub/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 15a184b440ad..5947dc3804af 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -219,7 +219,8 @@ post-patch:
@${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
@${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' \
+ s|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|/usr/X11R6|${X11BASE}|g' \
${WRKSRC}/configure \
${WRKSRC}/nsprpub/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 15a184b440ad..5947dc3804af 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -219,7 +219,8 @@ post-patch:
@${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
@${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' \
+ s|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|/usr/X11R6|${X11BASE}|g' \
${WRKSRC}/configure \
${WRKSRC}/nsprpub/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \