aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/clive1/Makefile49
-rw-r--r--multimedia/k9copy-kde4/Makefile22
-rw-r--r--multimedia/mplayer-skins/Makefile16
-rw-r--r--multimedia/mplayer-skins/Makefile.options139
4 files changed, 114 insertions, 112 deletions
diff --git a/multimedia/clive1/Makefile b/multimedia/clive1/Makefile
index 10b90b31e6dd..6f070f8a02a9 100644
--- a/multimedia/clive1/Makefile
+++ b/multimedia/clive1/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: clive
-# Date created: 2007-02-11
-# Whom: Nicola Vitale <nivit@FreeBSD.org>
-#
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= clive
PORTVERSION= 1.0.2
@@ -28,7 +24,7 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
# not compatible with 3.0
-USE_PYTHON= 2.5-2.7
+USE_PYTHON= -2.7
.if !defined(NO_INSTALL_MANPAGES)
MAN1= ${PORTNAME}.1 ${PORTNAME}-passwd.1
@@ -36,52 +32,53 @@ MAN1= ${PORTNAME}.1 ${PORTNAME}-passwd.1
CONFIGURE_ARGS= --with-doc=no
.endif
-OPTIONS= FEEDPARSER "Enable feed parsing" off \
- FFMPEG "Install ffmpeg for re-encoding" off \
- MPLAYER "Install mplayer as video player" off \
- NEWT "Install devel/newt (support for a simple GUI)" off \
- PYCRYPTO "Install pycrypto to encrypt login password" off \
- SQLITE3 "Install sqlite3 for caching visited URLs" off \
- VLC "Install vlc as video player" off \
- XCLIP "Install xclip (read URLs from clipboard)" off \
- XINE "Install xine as video player" off
+OPTIONS_DEFINE= FEEDPARSER FFMPEG MPLAYER NEWT PYCRYPTO SQLITE3 VLC XCLIP XINE
+FEEDPARSER_DESC= Feed parsing support
+FFMPEG_DESC= ffmpeg for re-encoding
+MPLAYER_DESC= mplayer as video player
+NEWT_DESC= simple GUI support
+PYCRYPTO_DESC= Encrypted login password support
+VLC_DESC= vlc as video player
+XCLIP_DESC= xclip (read URLs from clipboard)
+XINE_DESC= xine as video player
+
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FEEDPARSER)
+.if ${PORT_OPTIONS:MFEEDPARSER}
RUN_DEPENDS+= ${PKGNAMEPREFIX}feedparser>=4.1_2:${PORTSDIR}/textproc/py-feedparser
.endif
-.if defined(WITH_FFMPEG)
+.if ${PORT_OPTIONS:MFFMPEG}
RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
.endif
-.if defined(WITH_MPLAYER)
+.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
-.if defined(WITH_NEWT)
+.if ${PORT_OPTIONS:MNEWT}
RUN_DEPENDS+= newt${PYTHON_PKGNAMESUFFIX}>=0.51.0_4:${PORTSDIR}/devel/newt
.endif
-.if defined(WITH_PYCRYPTO)
+.if ${PORT_OPTIONS:MPYCRYPTO}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.0.1_1:${PORTSDIR}/security/py-pycrypto
.endif
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.5.2_1:${PORTSDIR}/databases/py-sqlite3
.endif
-.if defined(WITH_VLC)
+.if ${PORT_OPTIONS:MVLC}
RUN_DEPENDS+= vlc:${PORTSDIR}/multimedia/vlc
.endif
-.if defined(WITH_XCLIP)
+.if ${PORT_OPTIONS:MXCLIP}
RUN_DEPENDS+= xclip:${PORTSDIR}/x11/xclip
.endif
-.if defined(WITH_XINE)
+.if ${PORT_OPTIONS:MXINE}
RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
.endif
@@ -89,4 +86,4 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|g' \
${WRKSRC}/src/scripts/clive ${WRKSRC}/src/scripts/clive-passwd
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/k9copy-kde4/Makefile b/multimedia/k9copy-kde4/Makefile
index abc30b486fdb..0a8eb4da4ab1 100644
--- a/multimedia/k9copy-kde4/Makefile
+++ b/multimedia/k9copy-kde4/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: k9copy
-# Date created: 19 Dec 2005
-# Whom: Alexander V. Ribchansky <triosoft@triosoft.com.ua>
-#
+# Created by: Alexander V. Ribchansky <triosoft@triosoft.com.ua>
# $FreeBSD$
PORTNAME= k9copy
@@ -12,34 +9,35 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-kde4/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
MAINTAINER= egoliveira@gmail.com
-COMMENT= A DVD-9 to DVD-5 shrinking application for KDE
+COMMENT= DVD-9 to DVD-5 shrinking application for KDE
LIB_DEPENDS= xine:${PORTSDIR}/multimedia/libxine \
mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
avcodec:${PORTSDIR}/multimedia/ffmpeg
-USES= cmake
+USES= cmake gettext
USE_KDE4= kdeprefix kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
LATEST_LINK= ${PORTNAME}-kde4
-OPTIONS= MENCODER "Install MEncoder (requires MPlayer)" Off \
- MPLAYER "Install MPlayer" Off \
- DVDAUTHOR "Install DVD Author" Off
+OPTIONS_DEFINE= MENCODER MPLAYER DVDAUTHOR
+MENCODER_DESC= MEncoder support
+MPLAYER_DESC= MPlayer support
+DVDAUTHOR_DESC= DVD Author support
.include <bsd.port.options.mk>
-.if defined(WITH_MENCODER)
+.if ${PORT_OPTIONS:MMENCODER}
RUN_DEPENDS+= mencoder:${PORTSDIR}/multimedia/mencoder
.endif
-.if defined(WITH_MPLAYER)
+.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
-.if defined(WITH_DVDAUTHOR)
+.if ${PORT_OPTIONS:MDVDAUTHOR}
RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor
.endif
diff --git a/multimedia/mplayer-skins/Makefile b/multimedia/mplayer-skins/Makefile
index c49dc31a54ac..8e945c9af421 100644
--- a/multimedia/mplayer-skins/Makefile
+++ b/multimedia/mplayer-skins/Makefile
@@ -28,6 +28,7 @@ NO_BUILD= yes
.include "${.CURDIR}/Makefile.options"
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.include "${.CURDIR}/Makefile.skins"
@@ -42,26 +43,19 @@ post-extract:
@${FIND} ${WRKSRC} -type d \( -name '.svn' \) -delete
pre-build:
-# Build and install all skins (rather expensive)
-.if (defined(BATCH) && !defined(_OPTIONS_READ)) || defined(WITH_SKIN_ALL)
-.for f in ${ALLSKINS}
-WITH_SKIN_${f}= yes
-.endfor
-.endif # WITH_SKIN_ALL
+.if ${PORT_OPTIONS:MALL}
+PORT_OPTIONS+= ${ALLSKINS}
+.endif
post-build-script:
.for f in ${ALLSKINS}
-.ifdef(WITH_SKIN_${f})
+.if $(PORT_OPTIONS:M${f})
PLIST_SUB+= ${f}="" WITHOUT_SKIN_${f}="@comment "
-HAVE_SKIN= true
DISTFILES+= ${${f}_FILE}${EXTRACT_SUFX}
.else
PLIST_SUB+= ${f}="@comment " WITHOUT_SKIN_${f}=""
.endif
.endfor
-.if !defined(HAVE_SKIN)
-IGNORE= no skin selected
-.endif
do-install:
# both anotate and create target directories
diff --git a/multimedia/mplayer-skins/Makefile.options b/multimedia/mplayer-skins/Makefile.options
index 7d2652a3edb9..07f99ba86d36 100644
--- a/multimedia/mplayer-skins/Makefile.options
+++ b/multimedia/mplayer-skins/Makefile.options
@@ -3,66 +3,79 @@
# $FreeBSD$
#
-OPTIONS= SKIN_ALL "all skins" off
-OPTIONS+= SKIN_DEFAULT "the default MPlayer skin" on
-OPTIONS+= SKIN_DEFAULT_SMALL "compact version of the default skin" off
-OPTIONS+= SKIN_ABYSS "beautiful MPlayer skin" off
-OPTIONS+= SKIN_ALIENMIND "AlienMind XMMS" off
-OPTIONS+= SKIN_AVIFILE "aviplay look" off
-OPTIONS+= SKIN_ATERFILE "dark, cool-looking" off
-OPTIONS+= SKIN_BLUECURVE "bluecurve" off
-OPTIONS+= SKIN_BLUEHEART "BlueHeart XMMS" off
-OPTIONS+= SKIN_CANARY "small, compact" off
-OPTIONS+= SKIN_CLEARLOOKS "modern Clearlooks" off
-OPTIONS+= SKIN_CORELIAN "plain look" off
-OPTIONS+= SKIN_CORNERMP "WinAMP corner" off
-OPTIONS+= SKIN_CORNERMP_AQUA "WinAMP corner aqua" off
-OPTIONS+= SKIN_CUBICPLAYER "CubicPlayer" off
-OPTIONS+= SKIN_CYRUS "Cyrus XMMS" off
-OPTIONS+= SKIN_DISAPPEARER "very slim" off
-OPTIONS+= SKIN_DIVXPLAYER "Divx" off
-OPTIONS+= SKIN_DUSHKU "Eliza Dushku" off
-OPTIONS+= SKIN_DVDPLAYER "hardware player lookalike" off
-OPTIONS+= SKIN_GNOME "based on the GNOME logo" off
-OPTIONS+= SKIN_HANDHELD "remote control look" off
-OPTIONS+= SKIN_HAYRAPHON "Hayraphon" off
-OPTIONS+= SKIN_HWSW "simplistic" off
-OPTIONS+= SKIN_INDUSTRIAL "Industrial GTK theme" off
-OPTIONS+= SKIN_ICY "Nero ShowTime skin" off
-OPTIONS+= SKIN_ITUNES "iTunes" off
-OPTIONS+= SKIN_ITUNES_MINI "iTunes mini" off
-OPTIONS+= SKIN_PCLAND "blue waves" off
-OPTIONS+= SKIN_JIMPLAYER "round and colorful" off
-OPTIONS+= SKIN_KDE "uses KDE images" off
-OPTIONS+= SKIN_KRYSTAL "very colorful" off
-OPTIONS+= SKIN_MENTALIC "sharp and shiny" off
-OPTIONS+= SKIN_MIDNIGHTLOVE "XMMS skin of Rei Ayanami" off
-OPTIONS+= SKIN_MINI "MPlayer-plugin for mozilla" off
-OPTIONS+= SKIN_MOONPHASE "MoonPhase" off
-OPTIONS+= SKIN_MPLAYER_RED "MPlayer RED" off
-OPTIONS+= SKIN_NATIVE_RED "red and black" off
-OPTIONS+= SKIN_NETSCAPE4 "Netscape \"unatkozok\"" off
-OPTIONS+= SKIN_NEUTRON "futuristic look" off
-OPTIONS+= SKIN_NEWAGE "clean and simple" off
-OPTIONS+= SKIN_ORANGE "clean, good looking" off
-OPTIONS+= SKIN_OSXBRUSHED "iTunes lookalike" off
-OPTIONS+= SKIN_OSXMOD "QuickTime player lookalike" off
-OPTIONS+= SKIN_PHONY "desktop DVD player" off
-OPTIONS+= SKIN_PLASTIC "plastic remote control" off
-OPTIONS+= SKIN_POWERPLAYER "PowerDVD lookalike" off
-OPTIONS+= SKIN_PROTON "silver, shiny" off
-OPTIONS+= SKIN_QPLAYER "playful look" off
-OPTIONS+= SKIN_QUICKSILVER "QuickSilver" off
-OPTIONS+= SKIN_SESSENE "Sessene" off
-OPTIONS+= SKIN_SLIM "small and cute" off
-OPTIONS+= SKIN_SOFTGRIP "strange design" off
-OPTIONS+= SKIN_TERMINATOR3 "inspired by Terminator 3" off
-OPTIONS+= SKIN_TRIUM "based on a mobile phone" off
-OPTIONS+= SKIN_TVISOR "simple, well-designed" off
-OPTIONS+= SKIN_ULTRAFINA "XMMS ultrafina" off
-OPTIONS+= SKIN_WEBBY "Webby" off
-OPTIONS+= SKIN_WINDOWSMEDIAPLAYER6 "Windows Media Player 6" off
-OPTIONS+= SKIN_XANIM "XAnim feeling" off
-OPTIONS+= SKIN_XFCE4 "default XFce4 theme" off
-OPTIONS+= SKIN_XINE_LCD "xine LCD skin" off
-OPTIONS+= SKIN_XMMPLAYER "XMMS lookalike" off
+OPTIONS_MULTI= SKIN
+OPTIONS_MULTI_SKIN= ALL DEFAULT DEFAULT_SMALL ABYSS ALIENMIND AVIFILE ATERFILE BLUECURVE \
+ BLUEHEART CANARY CLEARLOOKS CORELIAN CORNERMP CORNERMP \
+ CUBICPLAYER CYRUS DISAPPEARER DIVXPLAYER DUSHKU DVDPLAYER \
+ GNOME HANDHELD HAYRAPHON HWSW INDUSTRIAL ICY ITUNES \
+ PCLAND JIMPLAYER KDE KRYSTAL MENTALIC MIDNIGHTLOVE \
+ MINI MOONPHASE MPLAYER NATIVE NETSCAPE4 NEUTRON NEWAGE \
+ ORANGE OSXBRUSHED OSXMOD PHONY PLASTIC POWERPLAYER \
+ PROTON QPLAYER QUICKSILVER SESSENE SLIM SOFTGRIP \
+ TERMINATOR3 TRIUM TVISOR ULTRAFINA WEBBY \
+ WINDOWSMEDIAPLAYER6 XANIM XFCE4 XINE XMMPLAYER
+ALL_DESC= All skins
+DEFAULT_DESC= The default MPlayer skin
+DEFAULT_SMALL_DESC= Compact version of the default skin
+ABYSS_DESC= Beautiful MPlayer skin
+ALIENMIND_DESC= AlienMind XMMS
+AVIFILE_DESC= Aviplay look
+ATERFILE_DESC= Dark, cool-looking
+BLUECURVE_DESC= Bluecurve
+BLUEHEART_DESC= BlueHeart XMMS
+CANARY_DESC= Small, compact
+CLEARLOOKS_DESC= Modern Clearlooks
+CORELIAN_DESC= plain look
+CORNERMP_DESC= WinAMP corner
+CORNERMP_AQUA_DESC= WinAMP corner aqua
+CUBICPLAYER_DESC= CubicPlayer
+CYRUS_DESC= Cyrus XMMS
+DISAPPEARER_DESC= very slim
+DIVXPLAYER_DESC= Divx
+DUSHKU_DESC= Eliza Dushku
+DVDPLAYER_DESC= hardware player lookalike
+GNOME_DESC= based on the GNOME logo
+HANDHELD_DESC= remote control look
+HAYRAPHON_DESC= Hayraphon
+HWSW_DESC= simplistic
+INDUSTRIAL_DESC= Industrial GTK theme
+ICY_DESC= Nero ShowTime skin
+ITUNES_DESC= iTunes
+ITUNES_MINI_DESC= iTunes mini
+PCLAND_DESC= blue waves
+JIMPLAYER_DESC= round and colorful
+KDE_DESC= uses KDE images
+KRYSTAL_DESC= very colorful
+MENTALIC_DESC= sharp and shiny
+MIDNIGHTLOVE_DESC= XMMS skin of Rei Ayanami
+MINI_DESC= MPlayer-plugin for mozilla
+MOONPHASE_DESC= MoonPhase
+MPLAYER_RED_DESC= MPlayer RED
+NATIVE_RED_DESC= red and black
+NETSCAPE4_DESC= Netscape \"unatkozok\"
+NEUTRON_DESC= futuristic look
+NEWAGE_DESC= clean and simple
+ORANGE_DESC= clean, good looking
+OSXBRUSHED_DESC= iTunes lookalike
+OSXMOD_DESC= QuickTime player lookalike
+PHONY_DESC= desktop DVD player
+PLASTIC_DESC= plastic remote control
+POWERPLAYER_DESC= PowerDVD lookalike
+PROTON_DESC= silver, shiny
+QPLAYER_DESC= playful look
+QUICKSILVER_DESC= QuickSilver
+SESSENE_DESC= Sessene
+SLIM_DESC= small and cute
+SOFTGRIP_DESC= strange design
+TERMINATOR3_DESC= inspired by Terminator 3
+TRIUM_DESC= based on a mobile phone
+TVISOR_DESC= simple, well-designed
+ULTRAFINA_DESC= XMMS ultrafina
+WEBBY_DESC= Webby
+WINDOWSMEDIAPLAYER6_DESC= Windows Media Player 6
+XANIM_DESC= XAnim feeling
+XFCE4_DESC= default XFce4 theme
+XINE_LCD_DESC= xine LCD skin
+XMMPLAYER_DESC= XMMS lookalike
+
+OPTIONS_DEFAULT= DEFAULT