aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/qtawesome/Makefile42
-rw-r--r--graphics/qtawesome/distinfo2
-rw-r--r--graphics/qtawesome/files/patch-QtAwesome.cpp18
-rw-r--r--graphics/qtawesome/pkg-descr10
-rw-r--r--graphics/qtawesome/pkg-message2
6 files changed, 75 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 304d48985c4d..a8c33616e0fa 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -878,6 +878,7 @@
SUBDIR += qt5-opengl
SUBDIR += qt5-pixeltool
SUBDIR += qt5-svg
+ SUBDIR += qtawesome
SUBDIR += qtgtl
SUBDIR += quat
SUBDIR += quat-gui
diff --git a/graphics/qtawesome/Makefile b/graphics/qtawesome/Makefile
new file mode 100644
index 000000000000..d243abcb3687
--- /dev/null
+++ b/graphics/qtawesome/Makefile
@@ -0,0 +1,42 @@
+# Created by: mi
+# $FreeBSD$
+
+PORTNAME= qtawesome
+PORTVERSION= 20150319
+CATEGORIES= graphics devel
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Embed Font Awesome glyphs in Qt-applications
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+USES= uidfix qmake
+
+GH_ACCOUNT= gamecreature
+GH_PROJECT= QtAwesome
+GH_TAGNAME= d674aef
+
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI= QT4 QT5
+OPTIONS_DEFAULT= QT4
+
+QT4_USE= qt4=corelib,gui,qmake_build
+QT5_USE= qt5=core,gui,qmake_build
+MAKE_ARGS+= ${PORT_OPTIONS:MQT*:S/QT/QT=/}
+
+WRKSRC= ${WRKDIR}/QtAwesome-${GH_TAGNAME}/QtAwesome
+#MAKEFILE= ${FILESDIR}/BSDmakefile
+EXTRACT_AFTER_ARGS=--no-same-owner --no-same-permissions \
+ --exclude QtAwesomeSample --exclude fonts
+PLIST_FILES= lib/libQtAwesome.so.1.0.0 lib/libQtAwesome.so.1.0 \
+ lib/libQtAwesome.so.1 lib/libQtAwesome.so \
+ include/QtAwesome.h
+USE_LDCONFIG= yep...
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,staticlib,sharedlib,' \
+ -e '/^RESOURCES/,$$d' \
+ ${WRKSRC}/QtAwesome.pro
+
+.include <bsd.port.mk>
diff --git a/graphics/qtawesome/distinfo b/graphics/qtawesome/distinfo
new file mode 100644
index 000000000000..48e49ab5d942
--- /dev/null
+++ b/graphics/qtawesome/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gamecreature-QtAwesome-20150319-d674aef_GH0.tar.gz) = 9f8a7b466ac71cd8393b858ba3255615dd7cb057d4df85ecb21073fc791f1f49
+SIZE (gamecreature-QtAwesome-20150319-d674aef_GH0.tar.gz) = 93887
diff --git a/graphics/qtawesome/files/patch-QtAwesome.cpp b/graphics/qtawesome/files/patch-QtAwesome.cpp
new file mode 100644
index 000000000000..58b5ec367b3f
--- /dev/null
+++ b/graphics/qtawesome/files/patch-QtAwesome.cpp
@@ -0,0 +1,18 @@
+--- QtAwesome.cpp 2015-03-19 20:21:38 UTC
++++ QtAwesome.cpp 2015-04-20 15:57:35 -0400
+@@ -155,6 +155,7 @@ void QtAwesome::init(const QString& font
+ /// To initialize QtAwesome with font-awesome you need to call this method
+ bool QtAwesome::initFontAwesome( )
+ {
++#if 0
+ static int fontAwesomeFontId = -1;
+
+ // only load font-awesome once
+@@ -189,6 +190,7 @@ bool QtAwesome::initFontAwesome( )
+ fontAwesomeFontId = -1; // restore the font-awesome id
+ return false;
+ }
++#endif
+
+ // intialize the map
+ QHash<QString, int>& m = namedCodepoints_;
diff --git a/graphics/qtawesome/pkg-descr b/graphics/qtawesome/pkg-descr
new file mode 100644
index 000000000000..40d26c2cb9b3
--- /dev/null
+++ b/graphics/qtawesome/pkg-descr
@@ -0,0 +1,10 @@
+QtAwesome is a simple library that can be used to add Font Awesome
+icons to your Qt application.
+
+NOTE: Though the name is QtAwesome and currently it's very Font
+Awesome based, you can use every other icon/glyph font you want.
+
+The class can also be used to manage your own dynamic code-drawn
+icons, by adding named icon-painters.
+
+WWW: https://github.com/gamecreature/QtAwesome
diff --git a/graphics/qtawesome/pkg-message b/graphics/qtawesome/pkg-message
new file mode 100644
index 000000000000..72e3797f1bb1
--- /dev/null
+++ b/graphics/qtawesome/pkg-message
@@ -0,0 +1,2 @@
+For the library to be useful, fontawesome-*.ttf must be known to
+fontconfig.