aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/pbm2ppa/Makefile75
-rw-r--r--print/pbm2ppa/distinfo1
-rw-r--r--print/pbm2ppa/files/asciippafilter.SH5
-rw-r--r--print/pbm2ppa/files/patch-aa9
-rw-r--r--print/pbm2ppa/files/patch-ab11
-rw-r--r--print/pbm2ppa/files/ppafilter.SH4
-rw-r--r--print/pbm2ppa/pkg-comment1
-rw-r--r--print/pbm2ppa/pkg-descr5
-rw-r--r--print/pbm2ppa/pkg-plist5
9 files changed, 0 insertions, 116 deletions
diff --git a/print/pbm2ppa/Makefile b/print/pbm2ppa/Makefile
deleted file mode 100644
index faa883d1c081..000000000000
--- a/print/pbm2ppa/Makefile
+++ /dev/null
@@ -1,75 +0,0 @@
-# New ports collection makefile for: pbm2ppa
-# Date created: 18 November 1998
-# Whom: smace@freebsd.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= pbm2ppa
-PORTVERSION= 0.8.6
-CATEGORIES= print
-MASTER_SITES= http://www.httptech.com/ppa/files/
-DISTFILES= ppa-${PORTVERSION}.tar.gz
-
-MAINTAINER= ports@FreeBSD.org
-
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript55 \
- enscript:${PORTSDIR}/print/enscript-letter
-
-USE_GMAKE= yes
-
-HPMODEL?= 720
-ALL_TARGET= ${HPMODEL}
-
-pre-configure:
-.if ${HPMODEL} != 720 && ${HPMODEL} != 820 && ${HPMODEL} != 1000
- @${ECHO} "HPMODEL is invalid: ${HPMODEL}."
- @${ECHO} "You must specify the model of your printer:"
- @${ECHO} "720 -- HP720 family (HP 722C, etc.)"
- @${ECHO} "820 -- HP820 family"
- @${ECHO} "1000 -- HP820 family"
- @${FALSE}
-.endif
-.if !defined(PAPERSIZE)
- @${ECHO}
- @${ECHO} "No PAPERSIZE environment variable found, will default to enscript-letter"
- @${ECHO}
-.endif
-
-do-install:
- ${SED} s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/ppafilter.SH > ${WRKSRC}/ppafilter
- ${SED} s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/asciippafilter.SH > ${WRKSRC}/asciippafilter
- cd ${WRKSRC} && \
- (${INSTALL_PROGRAM} pbm2ppa pbmtpg \
- ${PREFIX}/bin; \
- ${INSTALL_DATA} pbm2ppa.conf.hp${HPMODEL} \
- ${PREFIX}/etc/pbm2ppa.conf; \
- ${INSTALL_SCRIPT} ppafilter asciippafilter \
- ${PREFIX}/bin )
-
-post-install:
- @${ECHO}
- @${ECHO} "To configure your printcap to print either ascii"
- @${ECHO} "or Postscript files, add the following lines to your"
- @${ECHO} "/etc/printcap file"
- @${ECHO}
- @${ECHO} " lp|ascii|unix:\\"
- @${ECHO} " :lp=/dev/lpt0:\\"
- @${ECHO} " :sd=/var/spool/lpd:\\"
- @${ECHO} " :if=/usr/local/bin/asciippafilter:\\"
- @${ECHO} " :mx#0:\\"
- @${ECHO} " :sh:"
- @${ECHO}
- @${ECHO} " ps:\\"
- @${ECHO} " :lp=/dev/lpt0:\\"
- @${ECHO} " :sd=/var/spool/ps:\\"
- @${ECHO} " :if=/usr/local/bin/ppafilter:\\"
- @${ECHO} " :mx#0:\\"
- @${ECHO} " :sh:"
- @${ECHO}
- @${ECHO} "Please be sure that you install the proper flavor of"
- @${ECHO} "enscript, either A4 or Letter, by setting the PAPERSIZE"
- @${ECHO} "environment variable."
- @${ECHO}
-
-.include <bsd.port.mk>
diff --git a/print/pbm2ppa/distinfo b/print/pbm2ppa/distinfo
deleted file mode 100644
index d67eb8c1ab87..000000000000
--- a/print/pbm2ppa/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (ppa-0.8.6.tar.gz) = fb40576435d5979db64fbea305ec224b
diff --git a/print/pbm2ppa/files/asciippafilter.SH b/print/pbm2ppa/files/asciippafilter.SH
deleted file mode 100644
index 3b40c90e8c71..000000000000
--- a/print/pbm2ppa/files/asciippafilter.SH
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-CHANGETHIS/bin/enscript -B -q -p - | \
-CHANGETHIS/bin/gs -sDEVICE=pbm -q -dNOPAUSE -r600 -sOutputFile=- - | \
-CHANGETHIS/bin/pbm2ppa - -
diff --git a/print/pbm2ppa/files/patch-aa b/print/pbm2ppa/files/patch-aa
deleted file mode 100644
index 0b90a5ca90ef..000000000000
--- a/print/pbm2ppa/files/patch-aa
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile.orig Tue Sep 22 22:47:02 1998
-+++ Makefile Tue Sep 22 22:47:23 1998
-@@ -1,5 +1,5 @@
- CC=gcc
--CFLAGS=-Wall -O2
-+CFLAGS=-Wall -O2 -DPPA_CONF=\"${PREFIX}/etc/pbm2ppa.conf\"
- LDFLAGS=
-
- default:
diff --git a/print/pbm2ppa/files/patch-ab b/print/pbm2ppa/files/patch-ab
deleted file mode 100644
index 46fba083a417..000000000000
--- a/print/pbm2ppa/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- pbm2ppa.c.orig Mon Apr 6 23:20:07 1998
-+++ pbm2ppa.c Tue Sep 22 22:37:45 1998
-@@ -268,7 +268,7 @@
- exit(1);
- }
-
--char* defaultcfgfile="/etc/pbm2ppa.conf";
-+char* defaultcfgfile=PPA_CONF;
- int main (int argc, char *argv[])
- {
- int argn;
diff --git a/print/pbm2ppa/files/ppafilter.SH b/print/pbm2ppa/files/ppafilter.SH
deleted file mode 100644
index 0b27e4c44c17..000000000000
--- a/print/pbm2ppa/files/ppafilter.SH
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-CHANGETHIS/bin/gs -sDEVICE=pbm -q -dNOPAUSE -r600 -sOutputFile=- - | \
-CHANGETHIS/bin/pbm2ppa - -
diff --git a/print/pbm2ppa/pkg-comment b/print/pbm2ppa/pkg-comment
deleted file mode 100644
index 37ca750a6560..000000000000
--- a/print/pbm2ppa/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Convert PBM images to PPA for some HP printers
diff --git a/print/pbm2ppa/pkg-descr b/print/pbm2ppa/pkg-descr
deleted file mode 100644
index 0fb5313b00b2..000000000000
--- a/print/pbm2ppa/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This software creates output using the PPA (printer performance
-architecture) protocol. This protocol is used by some HP "Windows-only"
-printers, including the HP Deskjet 820C series, the HP DeskJet 720 series,
-and the HP DeskJet 1000 series. It has been tested on all three printers,
-but your personal experience (positive or negative) is very much appreciated!
diff --git a/print/pbm2ppa/pkg-plist b/print/pbm2ppa/pkg-plist
deleted file mode 100644
index cefab9ff6810..000000000000
--- a/print/pbm2ppa/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/pbm2ppa
-bin/pbmtpg
-bin/ppafilter
-bin/asciippafilter
-etc/pbm2ppa.conf