aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/stepulator/Makefile28
-rw-r--r--math/stepulator/distinfo3
-rw-r--r--math/stepulator/pkg-descr5
-rw-r--r--math/stepulator/pkg-plist12
5 files changed, 49 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 99e61d4ab2a1..4213a00c2bfc 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -320,6 +320,7 @@
SUBDIR += spooles
SUBDIR += spooles-mpich
SUBDIR += ss
+ SUBDIR += stepulator
SUBDIR += superlu
SUBDIR += superlu_mt
SUBDIR += surf
diff --git a/math/stepulator/Makefile b/math/stepulator/Makefile
new file mode 100644
index 000000000000..cc279aeee616
--- /dev/null
+++ b/math/stepulator/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: stepulator.app
+# Date created: 30 Aug 2006
+# Whom: gurkan@linuks.mine.nu
+#
+# $FreeBSD$
+#
+
+PORTNAME= stepulator
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= http://www.linuks.mine.nu/stepulator/ \
+ http://florida.ethz.ch/ports/distfiles/
+DISTNAME= ${PORTNAME}-gs-${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= gurkan@linuks.mine.nu
+COMMENT= Scientific calculator implementing RPN notation for GNUstep
+
+WRKSRC= ${WRKDIR}/Stepulator-gs
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+
+.include <bsd.port.mk>
diff --git a/math/stepulator/distinfo b/math/stepulator/distinfo
new file mode 100644
index 000000000000..7d800c017c93
--- /dev/null
+++ b/math/stepulator/distinfo
@@ -0,0 +1,3 @@
+MD5 (stepulator-gs-1.0.tar.Z) = ca745d84e3d24efde9966f35c24b47be
+SHA256 (stepulator-gs-1.0.tar.Z) = 35ee45bac0e5f1d829251f7a3f81be1cc372e4a489ba7f3529e1e658ffe50673
+SIZE (stepulator-gs-1.0.tar.Z) = 23966
diff --git a/math/stepulator/pkg-descr b/math/stepulator/pkg-descr
new file mode 100644
index 000000000000..2f6a1d72105e
--- /dev/null
+++ b/math/stepulator/pkg-descr
@@ -0,0 +1,5 @@
+Stepulator is a scientific calculator implementing the RPN notation.
+It is developed in Objective-C and is currently being maintained on GNUstep
+and Mac OS X (Cocoa).
+
+WWW: http://www.linuks.mine.nu/stepulator/
diff --git a/math/stepulator/pkg-plist b/math/stepulator/pkg-plist
new file mode 100644
index 000000000000..10c087fecbb3
--- /dev/null
+++ b/math/stepulator/pkg-plist
@@ -0,0 +1,12 @@
+Local/Applications/Stepulator.app/Resources/Info-gnustep.plist
+Local/Applications/Stepulator.app/Resources/Stepulator.desktop
+Local/Applications/Stepulator.app/Resources/Stepulator.gorm/data.classes
+Local/Applications/Stepulator.app/Resources/Stepulator.gorm/objects.gorm
+Local/Applications/Stepulator.app/Resources/StepulatorInfo.plist
+Local/Applications/Stepulator.app/Stepulator
+Local/Applications/Stepulator.app/library_paths.openapp
+Local/Applications/Stepulator.app/stamp.make
+@dirrm Local/Applications/Stepulator.app/Resources/Stepulator.gorm
+@dirrm Local/Applications/Stepulator.app/Resources
+@dirrm Local/Applications/Stepulator.app
+@dirrmtry Local/Applications