aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/io/Makefile.addons2
-rw-r--r--mail/dspam/Makefile2
-rw-r--r--net-im/imspector/Makefile3
-rw-r--r--security/maia/Makefile3
-rw-r--r--textproc/redland/Makefile2
-rw-r--r--www/dpsearch/Makefile2
6 files changed, 8 insertions, 6 deletions
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index fe6ad01af40d..2f2d1c0540bd 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -194,7 +194,7 @@ USE_XORG+= xmu
# PostgreSQL
#
.if ${PORT_OPTIONS:MPostgreSQL}
-USE_PGSQL= yes
+USES+= pgsql
.endif
#
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index bbaf1ff87027..11ada16d040d 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -202,7 +202,7 @@ PLIST_SUB+= PGSQL=""
#PKGNAMESUFFIX= -pgsql
_DBDRV_COUNT:= ${_DBDRV_COUNT}o
. if ${PORT_OPTIONS:MPGSQL_LOCAL}
-USE_PGSQL= server
+WANT_PGSQL= server
SUB_LIST+= PGSQL=postgresql
. else
SUB_LIST+= PGSQL=
diff --git a/net-im/imspector/Makefile b/net-im/imspector/Makefile
index 0cc9ebfb6d93..476a7a4f8eeb 100644
--- a/net-im/imspector/Makefile
+++ b/net-im/imspector/Makefile
@@ -31,7 +31,8 @@ IPFW_DESC= Add IPFW support
PLUGINS_DESC= Build plugins
IPFW_CFLAGS= -DIPFW_TRANSPARENT=1
-PLUGINS_USE= MYSQL=yes SQLITE=yes PGSQL=yes
+PLUGINS_USE= MYSQL=yes SQLITE=yes
+PLUGINS_USES= pgsql
.include <bsd.port.options.mk>
diff --git a/security/maia/Makefile b/security/maia/Makefile
index 959c59d3e790..a6a48e3bf424 100644
--- a/security/maia/Makefile
+++ b/security/maia/Makefile
@@ -154,7 +154,8 @@ RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if ${PORT_OPTIONS:MPGSQLSERVER}
-USE_PGSQL= server
+USES:= ${USES:Npgsql} pgsql
+WANT_PGSQL= server
.endif
.if ${PORT_OPTIONS:MDOVECOT}
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 78c3ce7a2273..8f9bb18c8d29 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -51,7 +51,7 @@ PLIST_SUB+= MYSQL="@comment "
#.endif
#.if defined(WITH_PGSQL)
-#USE_PGSQL= yes
+#USES+= pgsql
#CONFIGURE_ARGS+=--with-postgresql=yes
#PLIST_SUB+= PGSQL=""
#.else
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index 687f61c12af2..45ec095d0fa8 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -71,7 +71,7 @@ OPTIONS_SUB= yes
APACHE_USE= APACHE=22+
APACHE_CONFIGURE_ENABLE= apache-module
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql=${LOCALBASE}
MYSQL_USE= MYSQL=yes