aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/lxshortcut/Makefile56
-rw-r--r--deskutils/lxshortcut/distinfo4
-rw-r--r--deskutils/lxshortcut/files/lxshortcut-start.in6
-rw-r--r--deskutils/lxshortcut/pkg-descr9
-rw-r--r--deskutils/lxshortcut/pkg-plist77
6 files changed, 153 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index ada88753860e..d9b07fa3e86f 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -139,6 +139,7 @@
SUBDIR += ljclive
SUBDIR += ljit
SUBDIR += logjam
+ SUBDIR += lxshortcut
SUBDIR += mcal
SUBDIR += mdh
SUBDIR += mencal
diff --git a/deskutils/lxshortcut/Makefile b/deskutils/lxshortcut/Makefile
new file mode 100644
index 000000000000..15f167da2267
--- /dev/null
+++ b/deskutils/lxshortcut/Makefile
@@ -0,0 +1,56 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lxshortcut
+PORTVERSION= 0.1.2
+CATEGORIES= deskutils
+MASTER_SITES= SF/lxde/LXShortcut%20%28edit%20app%20shortcut%29/LXShortcut%20${PORTVERSION}/ \
+ SF/nemysisfreebsdp/lxde/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Small utility used to edit easily application shortcuts
+
+LICENSE= GPLv3
+
+USES= gmake pkgconfig
+USE_GNOME= gtk20 intlhack
+GNU_CONFIGURE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS NLS
+
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+
+SUB_FILES= ${PORTNAME}-start
+
+DESKTOP_ENTRIES="LXShortcut" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}-start" "Settings;GTK;DesktopSettings;" true
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -i '' '/g_thread_init/,/gdk_threads_init/d' \
+ ${WRKSRC}/src/lxshortcut.c
+
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|src po|src|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-start ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/deskutils/lxshortcut/distinfo b/deskutils/lxshortcut/distinfo
new file mode 100644
index 000000000000..238d8afaa861
--- /dev/null
+++ b/deskutils/lxshortcut/distinfo
@@ -0,0 +1,4 @@
+SHA256 (lxshortcut-0.1.2.tar.gz) = 8097f2522657374162a4e5e3c58898fe0c367e307b0ff4c50848b6b0323409fe
+SIZE (lxshortcut-0.1.2.tar.gz) = 224223
+SHA256 (lxshortcut.png) = f56c605dd2c271aad5a2627227ad70c53b2861ccf46e918cdb8e03e1d6dff75f
+SIZE (lxshortcut.png) = 3754
diff --git a/deskutils/lxshortcut/files/lxshortcut-start.in b/deskutils/lxshortcut/files/lxshortcut-start.in
new file mode 100644
index 000000000000..900242441b53
--- /dev/null
+++ b/deskutils/lxshortcut/files/lxshortcut-start.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+lxshortcut -o %U
diff --git a/deskutils/lxshortcut/pkg-descr b/deskutils/lxshortcut/pkg-descr
new file mode 100644
index 000000000000..61b3e79c2163
--- /dev/null
+++ b/deskutils/lxshortcut/pkg-descr
@@ -0,0 +1,9 @@
+LXShortcut is a small program used to edit easily application shortcuts
+created with freedesktop.org Desktop Entry spec.
+
+It’s mainly designed to be called by other LXDE components, and not directly
+used by the users. If you want to use it manually, see
+
+ lxshortcut --help
+
+WWW: http://wiki.lxde.org/en/LXShortCut
diff --git a/deskutils/lxshortcut/pkg-plist b/deskutils/lxshortcut/pkg-plist
new file mode 100644
index 000000000000..1f19ec36cbb1
--- /dev/null
+++ b/deskutils/lxshortcut/pkg-plist
@@ -0,0 +1,77 @@
+bin/lxshortcut
+bin/lxshortcut-start
+%%NLS%%share/locale/af/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/am/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/be/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/da/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/de/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/el/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/es/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/es_VE/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/et/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/fo/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/frp/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/he/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/id/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/it/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/km/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/lg/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ps/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/si/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/te/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/th/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/tt_RU/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/lxshortcut.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/lxshortcut.mo
+%%DATADIR%%/choose-icon.ui
+%%DATADIR%%/lxshortcut.ui
+share/pixmaps/lxshortcut.png
+@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/tt_RU
+%%NLS%%@dirrmtry share/locale/lg/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/lg
+%%NLS%%@dirrmtry share/locale/frp/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/frp
+%%NLS%%@dirrmtry share/locale/es_VE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_VE