aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ukrainian/ispell/Makefile8
-rw-r--r--www/aria2/Makefile4
2 files changed, 11 insertions, 1 deletions
diff --git a/ukrainian/ispell/Makefile b/ukrainian/ispell/Makefile
index fb455002435f..a6f7fc647a2a 100644
--- a/ukrainian/ispell/Makefile
+++ b/ukrainian/ispell/Makefile
@@ -38,4 +38,10 @@ do-install:
${PREFIX}/share/ispell/ukrainian.dict
${INSTALL_SCRIPT} ${FILESDIR}/ispell-uk ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc" && ${OSVERSION} > 900000
+BROKEN= Does not install on powerpc-9
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index e73c1b41bdea..797908d848fb 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -58,6 +58,10 @@ OPTIONS= SQLITE "Support for Firefox cookies" Off
.include <bsd.port.pre.mk>
+.if ${ARCH} == "powerpc" && ${OSVERSION} > 900000
+BROKEN= Does not install on powerpc-9
+.endif
+
.if defined(WITH_SQLITE)
CONFIGURE_ARGS+= --with-sqlite3
LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3