aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/pinot/Makefile9
-rw-r--r--mail/textmail/Makefile9
-rw-r--r--print/pdfcolorsplit/Makefile8
3 files changed, 16 insertions, 10 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 0602f273f134..bb33430f6f40 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pinot
PORTVERSION= 0.98
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
#MASTER_SITES= http://colinf.chez.com/pinot/
@@ -40,8 +40,6 @@ RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info \
unrtf:${PORTSDIR}/textproc/unrtf \
catdvi:${PORTSDIR}/print/catdvi
-BROKEN= unsatisfiable dependency on xpdf
-
PROJECTHOST= ${PORTNAME}-search
LDFLAGS+= -L${LOCALBASE}/lib
@@ -94,6 +92,11 @@ post-extract:
# remove pre-generated messages catalogs
${FIND} ${WRKSRC}/po -name "*.gmo" -delete
+post-patch:
+ ${REINPLACE_CMD} -e \
+ '/<command>/s|pdftotext|${LOCALBASE}/libexec/xpdf/pdftotext|' \
+ ${WRKSRC}/Tokenize/filters/external-filters.xml
+
pre-configure:
${REINPLACE_CMD} -e 's|-lthr|${PTHREAD_LIBS}|' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|' \
diff --git a/mail/textmail/Makefile b/mail/textmail/Makefile
index 1b2cc81f401a..a204e6873381 100644
--- a/mail/textmail/Makefile
+++ b/mail/textmail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= textmail
PORTVERSION= 20070803
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://raf.org/textmail/ CENKES
@@ -18,15 +18,16 @@ RUN_DEPENDS= antiword:${PORTSDIR}/textproc/antiword \
catdoc:${PORTSDIR}/textproc/catdoc \
xls2csv:${PORTSDIR}/textproc/catdoc \
lynx:${PORTSDIR}/www/lynx \
- pdftotext:${PORTSDIR}/graphics/xpdf
-
-BROKEN= unsatisfiable dependency on xpdf
+ ${LOCALBASE}/libexec/xpdf/pdftotext:${PORTSDIR}/graphics/xpdf
USE_PERL5= yes
PLIST_FILES= bin/${PORTNAME}
NO_WRKSUBDIR= yes
MAN1= ${PORTNAME}.1
+post-patch:
+ @${REINPLACE_CMD} -e '3s|^|\${.newline}$$ENV{'PATH'} = "${LOCALBASE}/libexec/xpdf:$$ENV{'PATH'}";\${.newline}|' ${WRKSRC}/${PORTNAME}
+
do-build:
@cd ${WRKSRC}/&&pod2man ${PORTNAME}>${PORTNAME}.1
diff --git a/print/pdfcolorsplit/Makefile b/print/pdfcolorsplit/Makefile
index 065612705421..96442dd48f99 100644
--- a/print/pdfcolorsplit/Makefile
+++ b/print/pdfcolorsplit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pdfcolorsplit
PORTVERSION= 2011.08.26
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= http://files.bsdroot.lv/my/FreeBSD/distfiles/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,9 +18,7 @@ COMMENT= Split your pdf into 2 pdf, color and bw, for printing
LICENSE= GPLv2
RUN_DEPENDS= pdftk:${PORTSDIR}/print/pdftk \
- pdftoppm:${PORTSDIR}/graphics/xpdf
-
-BROKEN= unsatisfiable dependency on xpdf
+ ${LOCALBASE}/libexec/xpdf/pdftoppm:${PORTSDIR}/graphics/xpdf
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
@@ -30,6 +29,9 @@ PLIST_FILES= bin/${PORTNAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
+post-patch:
+ @${REINPLACE_CMD} -e '/os\.system/s|pdftoppm|${LOCALBASE}/libexec/xpdf/pdftoppm|g' ${WRKSRC}/${PORTNAME}
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/